0

I've got a Jawbone ICON, which is paired to my PS3, my Macbook Air, and my iPhone 4. Most of the time I'm using it with my Macbook with A2DP. The problem is that when I turn it on, my iPhone automatically connects to it, and hogs the A2DP profile, so then my Mac can't connect to the thing at all. I sort of like this behavior, so my best solution would be if there was some way to "kick" the ICONs connection to my iPhone from my Mac. It's really difficult because I use it alot with my Mac and my iPhone, so I can't delete one of the profiles, and I need to use A2DP on both devices. What are your suggestions on ways to fix this?

1

'Forgetting' is overkill for what you want.

It would be easier to just turn the iPhone off before you turn the Jawbone on. Or turn Bluetooth off.

I have to do this sometimes because I have two phones that the Jawbone is paired with. When I turn it on, it will try to re-connect with the last one used.

Also, if it is connected to the iPhone, you can drop the connection from within the Bluetooth settings.

2
  • Thanks for the answer. What I actually found out is something like this. It turns out that unless my iPhone is currently receiving a call (in which case pairing is almost instant), my Jawbone has a significant delay of about 3-5 seconds before it pairs with my phone. In that time, I can be waiting to hit the "Use as Audio Device (Stereo)" button on my Mac. Then to switch it over I'll just power toggle it again. Jan 26 '11 at 16:41
  • My pleasure. I have the previous gen Jawbone, and I use it with a BB and an iPhone. I have call forwarding from my office phone to my BB but usually use the iPhone for outgoing calls (don't ask why). So the Jawbone was always connecting to the phone I didn't want it to. Disabling Bluetooth was the easiest solution because it's quick.
    – mockman
    Feb 4 '11 at 4:17
0

I don't think you can do this from the Mac. You can definitely have the iPhone forget the headset and pair it again later, though. Setting --> General --> Bluetooth --> tap blue ">" next to Jawbone —> "Forget this connection."

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.