73

I've got an ASUS K50AF series notebook with Windows 7 Home Premium x64. I'm using VLC media player, and I want to use media keys (play, pause, rewind, forward, stop) with it. Currently, they're associated with Windows Media Center.

My keyboard

I've tried MK2MP. Unfortunately, it didn't fix my problem, and crashed after restarting VLC media player.

Run time error 31
at line 559

Now, I can't even start MK2MP. Any ideas?

I've disabled Media Center and Media Player. HIP now recognizes media keys, but the keys still don't do anything.

It seems that when I try capturing that key, all programs (including HIP, Key Mapper and AutoHotkey) thinks I pressed the H key.

4
  • Is there some kind of keyboard control panel by the manufacturer that lets you customize what each key does? Feb 1, 2011 at 0:05
  • No, I haven't found anything like that.
    – nyuszika7h
    Feb 1, 2011 at 12:07
  • Brad's answer works. It should be the accepted answer. Dec 29, 2014 at 22:10
  • @PeterMortensen I have no way of verifying whether it works for me, since I don't even have that laptop anymore.
    – nyuszika7h
    Dec 29, 2014 at 22:12

10 Answers 10

114

You need to bind your keys in VLC media player. Other answers were right on this, but they were missing a couple of details which I am pointing out here.

  1. Start VLC media player
  2. Click menu ToolsPreferences
  3. Click the Hotkeys section near the bottom left.
  4. Find the action you want to bind and double click in the "Global" column. If you double click anywhere else, you will be binding the wrong keyboard shortcut.
  5. Press your key. VLC media player should recognize it.
  6. Restart VLC media player. If you are binding global hotkeys, VLC media player must be restarted, so it can listen for them.

VLC media player global hotkeys

15
  • 4
    This should be the accepted answer. Worked for me. Aug 19, 2014 at 15:54
  • 3
    In contrast to Shekhar's answer, this worked for me (after restarting VLC media player!!!!!!). And yes, it should be the accepted answer. +1. Dec 29, 2014 at 22:07
  • 7
    It works, but only when VLC has focus.
    – Umair
    Sep 28, 2015 at 17:31
  • 2
    Some people were able to get it working "Globally" by restarting VLC, others (like myself) had to restart the computer. If this doesn't work, you might have other issues like another program intercepting the signal, like Spotify or something.
    – BillyNair
    Nov 5, 2015 at 19:56
  • 2
    When I press play and pause key it doesn't show up in VLC. What should I do? Aug 18, 2016 at 7:20
12

Before you set the VLC hotkeys, you need to set VLC as your default media player, in control panel, default programs, set your default programs, and choose VLC as default.

The global hotkeys should then work with VLC, you still have to set them in VLC - tools, preferences, hotkeys, double click on the global key you want to set, VLC will prompt you to press the key, and restart VLC afterwards so they become active.

4
  • Are you sure that works? Isn't the only choice, except for Windows Media Player, "Use my current media player"? Dec 29, 2014 at 22:28
  • 1
    That doesn't work, there is no "default media player" as such. It's possible to associate VLC with a number of media extensions, but it doesn't make it "default" anyhow. Dec 5, 2015 at 22:25
  • 1
    This answer worked for me in Windows 10 - setting VLC as the "Default app settings" app for "Music player" and "Video player" then restarting VLC didn't require any further configuration. Thanks @dananfear :o)
    – Andrew
    Sep 25, 2017 at 11:47
  • Also associate CDA extension with VLC so that multimedia key for media player can open vlc Aug 16, 2020 at 4:39
3

If you have Microsoft IntelliType installed (it happens automatically for certain keyboards), try un-installing it via "Add or Remove Programs".

Via http://forum.videolan.org/viewtopic.php?f=14&t=79605

3
  • thanks for trying to help, but I'm sure I didn't have it installed (I don't use Windows anymore).
    – nyuszika7h
    Oct 4, 2011 at 16:28
  • 1
    I had to uninstall "Microsoft Mouse and Keyboard Center". Thanks!
    – localhost
    Apr 16, 2015 at 11:19
  • This was the one which worked for me, since it was my case. This is definitely weird, since it works with any other application I've already tried it. It filters only the Play/Pause button, making VLC recognize it as "Unset". Go figure how VLC recognizes the key like this, but anyway, I could register it. Still, it doesn't work globally, even after restarting VLC. Let's see after the next system restart. Mar 18, 2020 at 2:42
3

None of the previous solutions should work, as the problem is in the ATK Media utility provided by Asus. Instead of emitting keyboard events (like normal media keys), it maps them to specific applications (you can actually change those applications in the registry, see here http://mcbx.netne.net/hacks/asusmmed/index.htm).

The order and name of applications that it looks for change depending on version and system, but luckily there's an easier fix to enable the use of generic media key events.

I just came across the solution for this after some time reading a bunch of sites.

  1. Download the rar package from this blog post: http://3mptylab.blogspot.it/2012/09/how-to-make-asus-notebooks-media-keys.html

  2. Stop the current DMedia.exe process.

  3. Go to your ATK Media install folder (normally C:\Program Files (x86)\ASUS\ATK Package\ATK Media) and rename DMedia.exe to DMedia.exe.old (just to be safe).

  4. Put DMedia.exe you'll find in the RAR into the ATK Media directory. Double click it to run it, but it gets run at boot anyway.

  5. Check if the media keys work as they should. Grab a beer or watch a movie if it works!

I just tested it on my Asus U30Jc under Windows 8 Pro 64-bits, and it works great! This tool actually maps generic keyboard events to the media keys in the integrated keyboard, so they work with any application enabled for this (in some cases like Winamp you might need to enable global keys).

After enabling hotkeys in VLC media player, it should work with no problems, and with any other media program too (Spotify, Windows Media Player, Winamp, Xbox Music, etc).

1
  • Nice find, sadly I can't test it as my new laptop doesn't have media keys.
    – nyuszika7h
    Apr 29, 2014 at 16:30
2

You could set up macros in Event Ghost to capture the keys and set them up to trigger the actions that you want.

2
  • I can't see where can I add my media keyboard's Play button (or any other key) in this program.
    – nyuszika7h
    Feb 5, 2011 at 22:18
  • @Nyuszika7H: I see several Google results report this, try figuring it out... +1 Feb 6, 2011 at 14:22
2

For older VLC media player versions: Go to GeneralHotkeys in menu ToolsPreferences and try to bind your media keys.

The menu layout in newer VLC media player versions has changed and now you need to do the following:

Menu ToolsPreferencesHotkeys from the left hand menu on the window that opens up.

VLC media player menu screenshot

7
  • 4
    I've tried that, but VLC won't recgonize them.
    – nyuszika7h
    Jan 24, 2011 at 12:05
  • @Nyuszika7H : do the bindings work with any other keys ?
    – Shekhar
    Jan 24, 2011 at 12:11
  • 1
    Yes, they work with other keys, but not with media keys (when I press them, Media Center starts if it isn't started).
    – nyuszika7h
    Jan 24, 2011 at 12:26
  • 1
    Its obvious that your media keys are bound to media center , find a way to dissociate your keys from media center and it might work
    – Shekhar
    Jan 24, 2011 at 12:30
  • It almost worked when I tried it. It seems like the effect is like a media key is send two times. Thus for a key with toggle effect, play/pause, there is no effect (and double effect for the non-toggle keys). However, it may be a problem with my keyboard. It was tried on VLC media player 1.0.2. Dec 29, 2014 at 20:23
1

You might be able to use the article Disable Windows multimedia key shortcuts to disable the multimedia keys on Windows.

It counsels deleting entries from the registry key of HKLM\Software\Microsoft\Windows\CurrentVersion\Explorer\AppKey, so it is advised to first take some precautions.

To a lesser degree, you might also find the article How to Disable or Enable Windows Hotkeys in Vista useful although it may not apply to your case.

5
  • I've tried HIP, but unfortunately, it didn't work. :(
    – nyuszika7h
    Feb 1, 2011 at 7:56
  • Have you tried the registry method?
    – harrymc
    Feb 1, 2011 at 8:12
  • Hmm. .cda files are associated with VLC. So, what next?
    – nyuszika7h
    Feb 3, 2011 at 10:44
  • Sorry for being unclear. In my first link I was referring to searching HKLM\Software\Microsoft\Windows\CurrentVersion\Explorer\AppKey to maybe find out if the associations for the multimedia keys are defined there.
    – harrymc
    Feb 3, 2011 at 11:00
  • I know, I've read that article. I've tried deleting all, but nothing changed. Trying out other solutions.
    – nyuszika7h
    Feb 3, 2011 at 11:08
1
  1. Open up the hotkey window in VLC media player by menu ToolsPreferencesHotkeys
  2. Double click on the desired action to change
    • If you can set the media button to your desired hotkey.
    • If you cannot, unsetting the hotkey could help. You can do this by clicking Unset. This worked.

I also had problems with Windows Mouse & Keyboard Center. Uninstalling it helped use the sway.fm Chrome plugin (more details).

1
  • Thanks, but this is a very old question.
    – nyuszika7h
    Jun 24, 2014 at 10:50
0

I just had this problem, and it turned out that iTunes advanced setting "Enable full keyboard navigation" was checked. I unchecked it, and the keys worked in VLC media player again, without having to map them.

0

Try the following:

  1. Click Tools and select Preferences

  2. From the left hand side select Hotkeys

  3. You will now be prompted to select an action and associate it with a hotkey. Scroll down until you find the action Next and then double-click on it

  4. You should now be prompted to enter your media key for "Next Track"

  5. Click [Apply]

Once you do these five steps try playing a music/video file and testing ALL of your media keys as they should automatically work now.

1
  • 2
    On my Logietch MK700 keyboard, this does not work. VLC does not "see" the play/pause/fastforward/rewind buttons when pressed.
    – dan_linder
    Jun 7, 2013 at 20:18

Not the answer you're looking for? Browse other questions tagged or ask your own question.