5

I am trying to convert various video file formats into .webm using ffmpeg v. 0.6.1 but am having a few troubles. It creates the file but is zero kb in size. I also get the following error:

Encoder (codec id 146) not found for output stream #0.0

I have tried loads of fixes but none seem to work. I have used --enable-libvorbis on ./confure and downloaded the latest version of libvpx and all the other dependencies listed here: http://www.videochat-scripts.com/install-ffmpeg-mplayer-flvtool2-yamdi-x264-theora-mp3lame-vorbis-ogg-faac/

Are there any patches I need to apply from webm? Or is this version of ffmpeg meant to support it?

Anyone have any ideas? Thanks,

Chris.

7

For Mac users having the issue, this guy pointed out that you need to change the syntax slightly to include a codec in ffmpeg when installing with homebrew.

Example:

brew install ffmpeg --with-libvpx --with-theora --with-libogg --with-libvorbis

3

You need --enable-libvpx on your ./configure, e.g.:

./configure --enable-gpl --enable-version3 --enable-nonfree --enable-postproc --enable-libfaac --enable-libmp3lame --enable-libopencore-amrnb --enable-libopencore-amrwb --enable-libtheora --enable-libvorbis --enable-libvpx --enable-libx264 --enable-libxvid --enable-x11grab
  • I have solved it now but this may have worked instead of having to reinstall.Thank you! – Kit Feb 6 '11 at 17:21
1

I've solved it. The error was caused by a dodgy install of ffmpeg. Reinstalled and it works fine.

  • What was wrong with this answer? Voted undelete. – Kit Feb 25 '11 at 11:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.