Because of an error in data encryption, this session will now end.

This is the error I've been getting more and more frequently over the past few days, to the point that I can't ignore it because it's happening consistently within 5 minutes of connecting - sometimes within a few seconds. Both the remote and local machines are Windows 7 Pro x64. The remote machine is behind a Linksys RV082, and I'm using UPnP to forward a remote port to the correct local port. This setup had been working fine for several months, and I can't think of any recent relevant changes that might have been made.

Things I've already tried:

  • Disabling unnecessary components of the network connection on the remote machine, until only IPv4 and Client for Microsoft Networks remain.
  • Disabling TCP large send offload on both the remote and local machines.
  • Confirming that the remote machine is not mentioned anywhere in any DMZ settings on the Linksys router.
  • Confirming that there are no x509-related registry keys screwing things up (this is the suggested fix for a slightly different error anyway).

These are the only solutions I've been able to find after about an hour of searching, and most of them apply to XP or Server 2003 in any case. If anyone could suggest something else, it would be much appreciated.

  • I had this happen to me a few months ago. I would only get disconnected a few times a day, not as often or as quickly as it sounds like you did. Looking forward to seeing if anybody has any info, although mine has been fine for at least a month now. – G_P Jan 26 '11 at 21:34

I have been researching this as well and I feel like I went down the same road is you since every fix applies to vista/xp. However on Microsoft Technet I found someone who fixed this by deleting the certificate then reconnecting:

I just came across this error myself. I was attempting to remote desktop in from one XP machine >to another. To fix, I went into the Registry:


After exporting this for safekeeping, I deleted the Certificate keys. I restarted the target PC >and was able to successfully connect. I can only surmise that the problem is a corrupted >certificate or something. Deleting the certificate stored in the registry seems to have reset it. >The certificate key is different from the previous one, so maybe the target PC's certificate >expired?

Mostly just guesswork here, but this solution worked for me!

It may not be a definitive fix since this issue seems so random because it worked for months before now but I figured it's worth a shot for you to try.



Try deleting the string value for the machine you are trying to connect to under:HKEY_CURRENT_USER\Software\Microsoft\Terminal Server Client\Default

Let me know how it goes I'll check back when I get to my hotel after dinner.

  • Thanks, that's actually what I was referring to when I mentioned the x509 thing. That solves a slightly different error, and in any case, I didn't even have that key in the first place. – rfrankel Jan 26 '11 at 22:01
  • @frankel You don't have that key? I have windows 7 and I do. – Not Kyle stop stalking me Jan 26 '11 at 22:05
  • @rfrankel check my update. – Not Kyle stop stalking me Jan 26 '11 at 22:11
  • Correct, I do not have a Certificate key in HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\TermService\Parameters on either machine. The only keys in that folder are (Default), ServiceDll, and ServiceDllUnloadOnStop - this is true on both machines. The (Default) value for HKEY_CURRENT_USER\Software\Microsoft\Terminal Server Client\ was already blank on both machines. – rfrankel Jan 26 '11 at 22:18
  • very odd @rfrankel I have a huge bank of string values for machines that I have RDP'd to in the past. – Not Kyle stop stalking me Jan 26 '11 at 22:25

I had the same problem connectring Windows 7 to Windows 2008R2 server over rdp. I just did a clean install of my computer and it is simply not possible to connect over rdp. After removing Microsoft Sequrity Essesials and instead installing Symantec Endpoint Protection 12.1.2015 everything works just fine.


Had the same issue on my desktop, so: on the client side. For me the following solved the problem:

  • Removed the Citrix DNE Lightweight Filter
  • Removed the Virtual Machine Network Services
  • Removed the Virtual PC Network Filter service
  • Welcome to Super User! I don't know why someone downvoted, but maybe it was because the first sentence made them feel it was a "I have the same problem" post—I expected that too after reading that. I reshuffled a bit, though I cannot validate removing all these things is indeed a solution. – Arjan Aug 28 '13 at 11:32
  • On my system it was the issue.... and to be exact it was the Citrix DNE Filter... there is an update for the Citrix DNE driver... after applying it fixed the issue. So if anyone has the same Driver under network adapter... try updating it. citrix.com/lang/English/lp/lp_1680845.asp – user249193 Aug 30 '13 at 5:04

I had this issue, I gave up and I Re-Installed W7 on my Dell and RDP worked, only after copying my documents back did it fail again,

What I found was that I had copied the default.rdp file from the old PC and replaced the one on the new PC with it.

I Re-Installed W7 again and then this time didn't copy the default.rdp file over and the PC and RDP works perfectly. (I suppose system restore to a time when it was working could also work,)

After weeks of hunting this was the problem. 1 small file change.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.