45

I can sort files and directories in Windows Explorer by date modified. I always let recent files display first. But when I sort by date modified, directories are always displayed after the files.

Is it possible to sort files by date modified, but display directories before files?

  • Command line or the graphical file browser? – grawity Jan 28 '11 at 19:00
  • possible duplicate of Windows explorer: sort by date modified – Ƭᴇcʜιᴇ007 Aug 26 '13 at 14:57
  • sHr0oMaN's answer below worked for me, but FYI, if you use a Library instead of a regular folder, it sorts folders first in Date Modified mode. – Charles Mar 15 '16 at 0:50
8

I've been trying to do the same (i.e. distinguish the sort for folders from files, leaving files sorted by date). A clunky solution for win7 is suggested to me by another superuser post, making use of the 'group by' capabilities. If the file attributes are displayed in explorer (e.g. view > sort by > more... > [check 'attributes']), then you can group by attribute (essentially files vs. folders) using view > group by > attributes, and sort by date modified using view > sort by > date modified. With this, I can get folders to appear at the top, and files underneath this arranged by date.

Why would I want to do this? I'm by no way pedantic in how I organize files, but I do find I end up with a large directory structure - and typically when clicking through this, I'm usually interested in getting to subfolders. When I've reached the folder I want however, I usually will be wanting to access the most recently modified file. So having folders and recently modified files at the top saves scrolling.

  • 7
    Why was this accepted as the answer? Isn't OP trying to avoid the default behavior of automatically grouping files and folders separately during a sort? This doesn't answer the question... – Omar Jan 1 '13 at 4:09
  • You're right, this is a clunky, plus it doesn't always keep folders before files like the completely hidden answer by @sHr0oMaN – jla Aug 17 '15 at 18:08
  • This is not the answer. The answer is below at superuser.com/a/595669/427063. – Mark Cramer Oct 11 '16 at 14:57
84
+50

First, put the directory into “Details” view mode (if it isn’t already) so you have column headings.

If you click on the “Date Modified” heading, which will sort by Date Modified (descending), and then Shift+click on “Name”, it should remain sorted by Date Modified (descending), but with the folders at the top.

Note: This is observed as not working while the “preview pane” is enabled (Windows 7).  Simply disable the preview pane temporarily with Alt+P before sorting.  The preview pane can then be re-enabled and the sort method will remain.

To revert this, just click on whatever column you want to sort by.

Once you have the sort order that you want, you can switch into one of the other view modes (e.g., “Icons”, “List” or “Tiles”), and the presentation will retain the sort order that you specified.

  • 10
    This actually works (Tested on Win8.1). This is the only real solution I've seen that doesn't create other issues. – Bort Nov 29 '14 at 19:56
  • 1
    Works on Win7. Hate my company for making me work on Windows. – AlikElzin-kilaka Apr 28 '15 at 5:07
  • 1
    Worked perfectly on Windows 7, this is the best solution to this issue. – Jake Bathman Aug 4 '15 at 14:43
  • 9
    Worked for me on Windows 10 as well. – jenovachild Aug 10 '15 at 5:08
  • 3
    Thanks a lot for this. I know I'm a little late, but what is happening when you Shift Click on Name? Is that the secondary sort or something? – Charles Mar 15 '16 at 0:47
18

Try arranging the files by Date instead of Date Modified. I always have the problem with folders appearing before my files. It seems when you arrange by date, folders are displayed at the top regardless of the direction of arrangement. When you arrange by date modified, folders are always at the bottom in descending order.

  • 11
    Sorry but this is wrong and misleading. Please remember that "Date" works differently than "Date modified". If you download a document from the internet today, the file could have been last "saved" a year ago. Sorting by "Date" will likely put that file far in the past. "Date modified" will use the date the file was copied to your computer. Thus, it's important to realize that recently downloaded files may OR MAY NOT be near the top/bottom of the list when sorted by "Data". The ACTUAL solution is posted below by "sHr0oMaN". – Bort Nov 29 '14 at 19:55
3

In Windows:

dir /og-d

will sort directories first (g) then in most-recent-first (-d) order.

  • 1
    I, and the OP are interested in the sorting in Windows Explorer. Your command worked, but how do I make it apply to Windows Explorer? – jla Aug 17 '15 at 17:53
  • 1
    @jla: I answered the question before the OP added the Windows Explorer qualification. – Dennis Williamson Aug 17 '15 at 19:22
2

No, unfortunately this is how Windows Explorer behaves, it always groups the folders together before files (or after, depending on the sort direction).

Many users have complained and requested the ability to interleave files and folders like some other OSes do, but it is still not an option with Windows Explorer (though some alternative Windows shells and file-managers have implemented such a function).

  • I agree that it groups folders without group-by selected but pre 8.1 upgrade my folders always stayed on top no matter how I sorted. Now they only stay on top if I use a library view, otherwise they flop sides as you indicate. I'm pretty sure of this change, I nearly always sort by Date modified descending to grab the most recently built output so the change was immediately apparent and jarring to my process. – jla Aug 17 '15 at 18:02
  • Actually, if you set the directory as being "Photos" or "Video" then the folders will always be at top, regardless of sort direction. – apraetor May 11 '16 at 17:31
2

The @tryingToBeClever's answer worked for me, but with two additional steps:

  1. view > sort by > more... > [check 'Attributes']
  2. view > group by > Attributes
  3. view > sort by > Attributes
  4. view > sort by > Descending (or click on the Attributes tab)
  5. view > sort by > Date modified

I had to add steps 3 and 4, otherwise the attribute A of the files was always going first before that of the folders, i.e., D.

0
  1. Open the Properties pane for the folder in question
  2. Go to the "Customize" tab
  3. Change the folder content type to "Photos"

Folders will now always be kept at the top, regardless of sort direction.

protected by Community Jul 21 '13 at 5:30

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.