I'm using Windows 7 on a PC and connect to it via Remote Desktop Connection for Mac by MS, using a Mac. On the Mac, I have a 27" Display with 2560 x 1440 px resolution. The PC has a high performance graphics card (one of those that needs an additional power supply). Both machines are connected via network cable to a router. So network should be insanely fast.

However, the max resolution I can get is 1400 x 1050. The PC just has a old and bad 21" monitor connected to it.

How can I increase the resolution to 2560 x 1440 to work fullscreen with the Apple LED Cinema Display via Remote Desktop?

Maybe I shouldn't even ask, because I already experience some lag at the low resolution of 1400 x 1050. But I guess this can be resolved as well?

migrated from serverfault.com Feb 1 '11 at 13:18

This question came from our site for system and network administrators.

  • This is a year old post and should not be an issue anymore with the latest Mac RDP client. I'm currently using RDP for Mac 2.1.1 I have a 2011 Macbook Air connected to a 2011 Apple Thunderbolt display 27". I VPN frequently into my work PC which is an old Dell workstation running Windows 2008 R2 and I get the full resolution of 2560 x 1440. The only feature I'm missing is Windows Aero but that tends to slow things down when I RDP from a PC so I don't miss it much. – Won Lee Jan 19 '12 at 19:02

You can save your connection as a rpd file and edit that file in a text editor.

There you can edit it the DesktopHeight/Width value to any wanted value given that the remote machine supports it

  • As a point in interest, 2240x1280 seems to be the highest resolution my particular session will allow. Setting anything higher causes the session to die immediately after it connects. Not sure if this is a restriction of RDC, Lion or Server 2003. – jim0thy Oct 11 '11 at 10:14
  • My settings are written like this: desktopwidth:i:1920 desktopheight:i:1440 (saved .rdp file is not like xml, but rather line by line). But, when using remote desktop, resolution is not 1920x1440, but is much less than this. I don't understand why. On both machines (remote and desktop) are my settings the same: 1920x1440. – FrenkyB Oct 9 '15 at 13:31
  • I've also tried setting 'full screen', but the resolution over my RD session is still quite poor. – FrenkyB Oct 9 '15 at 13:40
  • I have confirmed that even though the MS RD Beta has changed to a completely alien looking config format, changing the desktopwidth and desktopheight still works. BTW, I love the Beta. It uses CMD+[CXV] for copy, cut, paste which makes my hands so very happy. – Bruno Bronosky Apr 5 '17 at 16:32

Microsoft Remote Desktop does not allow for larger resolutions than 1400x1050 (except with the Full Screen setting)

You could always use CoRD, an open-source Remote Desktop client for Mac OS X. You can specify the desired resolution for every machine you connect to there.

enter image description here

You can even configure custom screen resolutions in its preferences:

enter image description here

  • 1
    The display of the computer you connect to is not important for remote desktop connections, since the session is not displayed locally. You don't even need a screen connected on the server. – Daniel Beck Feb 1 '11 at 13:24
  • +1 for suggesting CoRD, that´s a way better Remote Desktop client than the one from Microsoft. – Asmus Feb 1 '11 at 13:32
  • Sadly CoRD doesn't seem to work on Mavericks according to the site, and last reported update was nearly 6 months ago. – Carlos P Mar 25 '14 at 11:02

You can increase the resolution of Microsoft's Remote desktop Client, which may be a better alternative to using CoRD at reduced security.

On MacOS using Microsoft's "Remote Desktop CLient for Mac v2.1.0", edit the file "default.rdp" located in your user folder. I use 1920x1080, which is the native resolution of my 21" iMac. This results in a perfect full screen display connecting to Windows 7 clients. I have no idea why the preferences UI is limited to 1400x1050 - it works find at all sorts of resolutions.

The only thing missing is Aero glass over RDP, which I enjoy all the time when going from Win7 to Win7 boxes.


Version 8.0.2 created a .rdp file I opened with Text Wrangler:

I had to update desktopwidth and desktopheight to 2560/1440 ... using the GUI didn't let me save this resolution.

This worked fine:

screen mode id:i:2
use multimon:i:1
session bpp:i:32
full address:s:xxxxxxxxxxx
disable wallpaper:i:0
disable full window drag:i:0
disable menu anims:i:0
disable themes:i:0
alternate shell:s:
shell working directory:s:
authentication level:i:2
connect to console:i:0
disable cursor setting:i:0
allow font smoothing:i:1
allow desktop composition:i:1
use redirection server name:i:0

1) On RDC / Mac, select your remote server from the list

2) Select "Edit" from the main menu

3) Select the desired resolution from the "Resolution" list

4) OK / Confirm this screen.

5) Double click on your remote connection, this will start, yes, it might not be in the resolution you like yet (i.e. parts of the screen might not show on your MAC yet).

6) Go to the main menu, click on "Window" and then select "Scaling", this should change the screen to the resolution you like.

I hope this helps


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.