I try to map a network resource to my local device.

I receive the following error: The local device name is already in use.

I have the problem to find which purpose the device is used for. I try a command net use and do not see it in the list, therefore, it is not mapped to a network resource.

Does anybody know how to see the list of all used devices in Windows 7?

  • net use is the typical way to check. I'm not sure why it would be claiming to be in use if it is not there.
    – Jeff F.
    Feb 1, 2011 at 14:30
  • @Jeff: exactly, also not clear for me
    – Timofey
    Feb 1, 2011 at 14:34
  • @Tim silly question: Have you rebooted? Also have you ensured that no physical device is using that letter(in disk management)
    – Jeff F.
    Feb 1, 2011 at 14:37
  • @Jeff: I use 2 physical disks that are partitioned into C:\ and V:\ correspondingly + 2 network resources that are mapped to W:\ and Z:\ as you see there is no I:\ among them. Why do I have to reboot?
    – Timofey
    Feb 1, 2011 at 14:42
  • @Tim reboots have been the universal MS fixer since 3.0 :)
    – Jeff F.
    Feb 1, 2011 at 14:43

17 Answers 17


You need to remap the drive.


net use * /delete

Then remap it using net use again:

net use Z: \\server\share /user:username password
  • thank you sir!! I had disconnected a device from the gui, but the device name was "already in use". Mar 15, 2012 at 13:36
  • 2
    Why do I have to do this? The drive died on me literally while moving a file. This is outrageous.
    – rr-
    Apr 5, 2015 at 10:29
  • Sadly this does not work sometimes. There is nothing to remove. It's a catch-22. There is nothing to remove, the drive letter is in use so you can't add a new map that uses it. Windows just fails with mapped drives periodically and even restarting the workstation service doesn't help. Mar 23, 2018 at 1:51
  • why would you unmount all devices instead of just the problematic one?
    – CervEd
    Apr 7, 2022 at 7:31

It happened to me when I woke the computer from overnight sleep. I started stopping service after service and it seems that the "Computer Browser" service was at fault in my case. Try:

net stop browser  
net start browser
  • 1
    Use "Run as Administrator", otherwise you'll get an Access Denied error. Jun 18, 2017 at 2:26
  • Worth noting that this can also be called simply as net start browser net stop browser which may save a few keystrokes of typing for those so bothered! Contending against unreliable connections, this is a much, much more agile method of recovery than a total reboot.
    – PowerLuser
    Jun 14, 2018 at 10:26
  • I get "The service name is invalid." Perhaps this service has been renamed in Windows 10.
    – Simon E.
    Jul 15, 2018 at 23:26
  • 1
    @SimonEast - you are correct, the new name is just Browser.
    – Mike
    Oct 24, 2019 at 7:46
  • This solved it for me when even restarting didn't. Actually I had to also do net start "Computer Browser" after net start browser but it worked. Thanks!
    – Clonkex
    Oct 30, 2020 at 4:13
  1. Delete the registry key
  2. Logoff, then logon

If it still does not work, disconnect all mapped drives either from GUI or command line as in the previous post, delete the reg key above, and then log off and log on

  • 1
    The other options wouldn't help for me, but this fixed it. What happend was that for some strange reason, a CD drive appeared at D: (it's a virtual machine) which conflicted with my existing network mapping on D:. Removing this key and logging off/on showed the CD drive. Apr 12, 2014 at 6:15

We had a Windows 7 laptop user whose printer was being mapped as the drive in question. But it wasn't showing up in Start->Computer and it wouldn't show up when listing with NET USE. However, if you went to Disk Management there was a removable media disk listed with no displayed drive letter that was mapped as the drive letter in question. If you right-clicked it, it would display EPSON in the properties.

We changed the drive letter to something that was not being used in Disk Management.

I asked my boss why a printer would map a drive, and he said it was so that the printer itself would deliver the drivers instead of Windows having to download them; but it assigns a drive letter without notifying some other Windows components apparently.

The errors that we got for it were Event ID 4098 with error code 0x80070055 in the application logs and when trying to map the drive letter with NET USE, Error 85 The local device name is already in use.

  • Good catch! In my case it was that Daemon Tools got wild and made about 7 virtual drives, which weren't shown on Windows Explorer, but yes on Disk Management as CDROMs
    – coloboxp
    Apr 16, 2018 at 7:33

It may be a little late to answer this for the OP, but since others will continue to find this through search engines (like I did), I will add a solution that worked for me.

I work in an IT Department, and some of our users where experiencing this error today. The solution was to enable File and Printer Sharing.

AVG Anti-virus was used, so this option had to be enabled through the anti-virus firewall settings, and not Windows. So you'll need to adjust how you enable it if needed.

In my experience, shared drives never work when AVG decides to disable "File and Printer Sharing", though I'll always receive an error asking me to "check the spelling" or something similar. I have never seen it throw the "..Already in use" error until today.


One possibility that I just ran into is that you've added a device to your system that causes other "auto mapped" devices to bump up over the mapped drive.

Say you have M: mapped to a network drive, but you add a new harddrive that then causes all the removable drives (even though they don't have anything inserted into them) to bump up a letter (or two).

Now, suddenly, one of the removable drives is mapped to M:, so your network drive can no longer be mapped to M:, and when you try to remove the mapping, it'll give you a Device already in use error.

Open up "Storage/Disk management" and check ALL the drives for any mapping that might be on top of the drive you want to map.

If there, just remap that drive to something else.

Then you should be able to use net use to attach to your network drive properly.


I ran into this today, on several windows 7 and linux clients mapping drives from a linux samba server. The problem turned out to be that my root drive on the server had run out of space. clearing up a few gigabytes and restarting the samba server fixed the problem.


There's an outside chance the cause of this is that the share you're trying to reach doesn't exist or has been disabled.

  • Yep. Think in my case the remote computer (a Mac) had gone into sleep mode or something.
    – Simon E.
    Nov 11, 2013 at 0:06

I was having the same issue on a Windows Server 2008 SBS while i was trying to connect to an old NAS.

After trying each of the suggestions i saw here, i wasn't able to fix this.

During troubleshooting i found out that the root of the issue could be one of the assigned server IP's.

Indeed that was. I went to NAS logs and i saw that it was adjusted to connect with the NAS admin username and password under a specific IP address which was assigned to the server instead of server's main IP address!

So for future reference, i would suggest to check if you are under multiple NICS on your machine. If so you might have to remap the network share from a particular location.

Also, don't forget to read the logs of each device carefully.


I had this problem, here is a possible solution, make sure your sharing server has space left on the OS or root drive or "/".

I run a samba server on linux and the root drive was full. If samba can't create logs it crash and from the windows side it fails with the error "local device name is already in use" for some obscure reason.


This sounds dumb, but I had it happen to me recently as well and I was pulling my hair out. Drives were set up with no credentials and there were no duplicate mappings. Drives were mapped by IP. In short, there should be no issues, but the drives would randomly disconnect for 2-3 minutes while in use.

It turns out that when I made a small network change, the users chose the "Public" option on the network popup instead of "Work".

Yes, switching it back to "Work" resolved it for me. You can do it under "Network and Sharing Center" from the start menu and then click on the Public icon to change it back to Work.

  • This does seem to solve quite different issue than what the OP asked.
    – zagrimsan
    Sep 13, 2016 at 5:53
  • @zagrimsan Actually I'm saying that I specifically had the exact same error that the user mentioned, with no trace of it being mapped per net use. When the network was set to public on the network adapter, for some reason either AV or firewall or something wasn't doing proper keep-alive. So the mapped drive would work for a bit then randomly stop working.
    – Mike H
    Mar 2, 2023 at 19:52

If you use a VPN to connect to the network that contains the network resource, the VPN can also cause this error:

In 'Network and sharing center', each network connection is given a network type (private/domain/home/public). I've seen situations where the VPN connection was stuck at 'Identifying...'. The network is considered Public until identification is finished, this means Windows Firewall will not allow connections to network drives via this connection.

Restarting the VPN usually solves the issue for me.


Replacing the hostname with its IP address solved the issue for me. Ping the hostname to find the IP address and replace the name with that IP address.

For example: I had this error with path \\it-share\software\deployment

I replaced it-share with its IP address like this: \\172.x.y.122\software\deployment

It worked!


I tried the top 3 Answers - 1. delete all mappings, 2. restart services and 3. delete reg key but those didn't work.

In a SO thread, solution given by @wimh fixed it for me. A system account was hogging the drive letter:



You need psexec if you can't see the mounted drives with "net use"

psexec \\localhost -s cmd

Here you need to use "net use" again, delete if they show up here, then try mounting/reconnecting again.


I had a user with the same issue, but the solution was different. Scenario was they were getting this issue on their laptop, which we swapped out, and new laptop doing the same thing.

This network uses Meraki to control the access points, and they have setup a splash page to accept the terms and conditions of using the connection. Turns out this user never did that and kept getting issues when changing to ethernet to wifi. Click accept and everything is fine.


I had the same issue (The local device name is already in use).

For me the issue was related to my subnet mask: the Windows server was in a /24 ( while my DHCP server was providing /23 (netmask For clients in /24 the connection went just fine, but for any clients that got a /23 address (e.g., the error appeared.

I could easily change the subnet mask on my Windows Server to /23 and this fixed the issue (no reboot required).

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .