A while ago I started having trouble with my optical drives. Both of them keep showing up in Explorer as CD/DVD drives on boot, but as soon as I put a disc in either one, it suddenly turns into a hard-drive—“local disk” is displayed in the Type column, though the File System column remains UDF/CDFS. (I though that maybe it was a permission issue on the registry key in HKLM\System\CurrentControlSet..., but I’m not so certain because of the next test.)

Here’s a screencast of My Computer; when I put in a disc, the DVD drive magically turns into a hard-disk and cannot be opened.

When I try to open a disc (of any type), I get an access denied error message. If I open an elevated command-prompt, I am able to access the files. Also, if I kill Explorer and run it from an elevated command-prompt (thus giving Explorer elevated permissions), then I can access the files from Explorer.

I’ve tried uninstalling and reinstalling the devices without success. The security dialog indicates that there are none set for the drives (no owner and no permissions). I tried setting the owner, but am only able to do so if there is a disc in it (it complains if it is empty), but the settings do not stick (if I immediately open the security dialog after setting it, it is empty again). I tried setting permissions, but that gives an error.

I’ve included a screencap-flowchart of the security dialog of one of the drives below.

I suspect that the problem is with the registry entries related to optical drives in HKLM\SYSTEM\CurrentControlSet. For example, the Properties subkey in HKLM\SYSTEM\CurrentControlSet\Control\Class\{4D36E965-E325-11CE-BFC1-08002BE10318} is conspicuously absent. Worse, I cannot figure out what should be in it or import one from a backup hive because the Properties subkeys in …\Class have some sort of “super-admin” permissions—I cannot even view the permissions or owner on these! It does say however that I can change them, but I don’t know what account owns or has permissions for them (my guess would be TrustedInstaller—or something).

(Yes, I made sure that there are no upper- or lower-filters, and yes, I ran sfc. I also made sure that in the policy editor, “devices: restrict CD-ROM...” and “removable storage access” are not set.)

Does anyone know what the owner and permissions are supposed to be for optical drives and how to reset them?

enter image description here

  • I know you checked "Devices: Restrict CD-ROM..." but did you also check Computer Configuration | Administrative Templates | System | Removable Storage Access? Feb 1, 2011 at 23:26
  • Yup; those are also all “not configured”.
    – Synetech
    Feb 1, 2011 at 23:26
  • Does it work okay with UAC disabled? (after a restart)
    – Kez
    Feb 19, 2011 at 22:57
  • @kez, yes, not surprisingly it does work, though is not correct or a solution (it has the same effect as starting Explorer from an elevated command-prompt). I suspect that there is something wrong with the permissions on the registry keys in HKLM\System related to the optical drives.
    – Synetech
    Feb 21, 2011 at 3:14

5 Answers 5


This behavior is very puzzling, so all I can offer are some hints and more questions.

It would help to know whether the CD/DVD drive is shared. If it is, maybe unsharing can help.

Second, whether you have a CD-burning software installed, such as Nero. You might try to uninstall such software to see if this makes a difference.

Third, run gpedit.msc and check Computer Configuration / Administrative Templates / System / Removable Storage Access. Verify that "CD and DVD: Deny read access" is disabled or not configured. In effect, all the options should be not configured.

You might also try to see what happens with "sfc /scannow" as described in
How to Repair Windows 7 System Files with System File Checker.

The last resort is following How to Do a Repair Install to Fix Windows 7, which will refresh your Windows files without requiring the reinstallation of applications.

Some anti-virus scans might also be useful.

  • I can see from your answer to KJGraphics that the drive is unshared, so don't bother replying on this.
    – harrymc
    Feb 21, 2011 at 9:13
  • 1
    Registry access to Properties is easy : in another computer do regedit, right-click the Properties key and select Permissions, click Advanced, change to yourself in Owner tab, Apply, then in Permissions tab add all permissions. Now you can export the whole class and import it to your computer. It should work with whatever owner. But create first a restore point on both computers, just in case.
    – harrymc
    Feb 25, 2011 at 6:31
  • 1
    I don't think you can or need to reset the owner to that hidden account. I believe it can still work with whatever owner. To be sure, I have suggested taking a restore-point, which you can restore-to at least on the source computer. The target computer will stay with Administrator as owner, and I believe that this will work. If not, then restore back.
    – harrymc
    Feb 26, 2011 at 6:51
  • 1
    This can work in spite of the frightening "access denied" message. Click OK on the message, then right-click on Properties and follow as per my advice above.
    – harrymc
    Feb 28, 2011 at 12:49
  • 1
    You should do it in the order : 1) become owner and click Apply, 2) give permissions.
    – harrymc
    Feb 28, 2011 at 20:20

Well, it turns out that I was right; it was indeed the missing Properties key in HKLM\SYSTEM\CurrentControlSet\Control\Class\{4D36E965-E325-11CE-BFC1-08002BE10318}. It took several steps to fix, but actually not that long overall (especially compared to the three or so weeks I’ve been living with and working around the problem).

  1. Grabbed a an offline copy of the SYSTEM hive from my previous installation of Windows-7 (the backup in %systemroot%\System32\Config\RegBack has the same problem)
  2. Mounted it in my current copy (> reg load hku\z system)
  3. Ran Regedit and navigated to HKU\z\SYSTEM\CurrentControlSet\Control\Class\{4D36E965-E325-11CE-BFC1-08002BE10318}
  4. Opened the permissions dialog for the Properties key, ignoring the errors and warnings about not being allowed to view permissions for the key
  5. Switched to Owner tab and set permission to myself
  6. Switched to main tab and added myself to the ACL and assigned full-control
  7. Refreshed and successfully viewed the Properties key and its contents
  8. Exported the key to a .REG file
  9. Unmounted the backup SYSTEM hive (> reg unload hku\z)
  10. Edited the .REG file to change the key (HKEY_USERS\z -> HKEY_LOCAL_MACHINE)
  11. Imported the updated .REG file
  12. Navigated to HKLM\SYSTEM\CurrentControlSet\Control\Class\{4D36E965-E325-11CE-BFC1-08002BE10318} in the registry
  13. Opened permissions dialog for Properties (no errors this time)
  14. In Owners tab, switched owner from myself to the virtual user SYSTEM
  15. In main tab, removed myself from permissions list and made sure SYSTEM has full access (iirc, it already did)
  16. Refreshed, unable to view key anymore (that’s good), closed Regedit
  17. Opened Device Manager
  18. Uninstalled optical (CD/DVD) drives
  19. Rebooted
  20. Inserted a disc to test, observed that it loaded without suddenly turning into a hard-disk, opened the disc in Explorer successfully.

It works correctly now (I can watch a DVD without having to rip it to the hard-drive or running the player in administrator mode, or I can install a game or program without having to open an admin command-prompt to install or even copy the whole disc to the HD).

I guess my instincts were correct from the start. If I had the time—um, at the time—I would have rolled up my sleeves and dug into that inaccessible key like I usually do. Thanks to harrymc for insisting on the key being accessible and pushing me to copy it.

(I’m still not sure what caused the problem in the first place. I do recall that there were other issues with the optical drives just before the key got deleted—Device Manager had kept marking them with an error/warning—and I recall trying various ways to forcibly uninstall the drives in an attempt to get Windows to detect and reinstall them correctly. It stands to reason that one of the forced uninstallations somehow managed to delete the key; it didn’t exactly improve the situation. On the bright side, the drives are no longer marked with warnings in Device Manager.)

  • Your method works very well. I also imported "HKLM\SYSTEM\CurrentControlSet\Control\Class\{4D36E965-E325-11CE-BFC1-08002BE10318}" from a previous backup and everything came back to normal. One question remains: what triggered the problem ? Gil
    – user111290
    Dec 28, 2011 at 21:21
  • You had the same problem? I’m glad I could help. I too saw the pages referencing that CLSID, but they did not help because I was not missing the CD/DVD drive, I just could not open it. I don’t know what could have caused it; it doesn’t help that it was quite a while ago, so I could never remember all the things that went on in my system back then.
    – Synetech
    Dec 29, 2011 at 20:28
  • Thanks for such detailed instructions about how to give yourself permissions to the Properties key :)
    – Rachel
    Dec 13, 2012 at 16:43

Today there was one 13-byte file on a CD I couldn't read on windows 10 home. However after creating a ISO-file (using BurnAware), I was able to extract it from there (using WinRAR).


I faced the same problem , what i did was:(Windows 7)

  • Ran Regedit and navigated to HKU\z\SYSTEM\CurrentControlSet\Control\Class{4D36E965-E325-11CE-BFC1-08002BE10318}

Right clicked, then click new, then create a new key. Then rename it to Properties. In Properties create two new dwords

  • DeviceType Type:reg_dword Value:00000002
  • DeviceCharacteristics Type:reg_dword Value:00000100

Then Uninstall the driver of cd/dvd from Device manager.

Scan for New Hardware. Boom!! Problem Solved.

  • I’m glad I could help fix it, but why did you create the two extra values? That should not be necessary; should get created automatically when the drivers are re-installed. Did you make sure to check the permissions?
    – Synetech
    Dec 22, 2013 at 19:21

I found that the Initio default controller" in the device manager needed to be uninstalled, including the driver files. After that the external USB DVD drive suddenly appeared again.

(To verify this, I let Windows Update reinstall the 52kb Update called Initio - Bus Controllers and Ports - Initio Default Controller, with the effect that DVD drive disappeared. Deleted driver again in device manager; DVD drive appeared again.)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.