I will receive meeting.ics (VCS/ICS calendar attachment) from my manager , previously I had some add-on in Thunderbird which was working fine . After some updates the meetings.ics file become as attachment , its not automatically added to calender?

What is the issue ? How can this be resolved?

Edit 2 : I have the Lightning Project, an extension also

  • none of the answer is solving my problem
    – joe
    Sep 13, 2009 at 20:35

6 Answers 6


It would be helpful if you could add a bit more information - what version of Thunderbird are you using? What version of Lightning are you using? What was the update (or updates) that caused the problem? What addon(s) are you using apart from Lightning?

Using Thunderbird 2.0 and Lightning 0.9 this works for me. You could backup your profile, uninstall the Lightning addon, uninstall Thunderbird, then reinstall Thunderbird 2.0 and the Lightning 0.9 addon.

  • This is may not be perfect solution . But works for me ;)
    – joe
    Sep 14, 2009 at 9:12
  • Glad to help! Lets hope these things become more reliable in subsequent releases.
    – Richard
    Sep 14, 2009 at 11:23

This is a known problem with the Thunderbird/Lightning combination. There is a small workaround though found here:

You need to set "display attachments inline", then you can accept or decline invites though a button at the top of the email-preview. You can also drag the ics-attachment to the calendar-button in the mode-toolbar. Lightning doesn't register itself as the default program for .ics files (yet).

  • This is work around also not working . and I am not able the slove issue with this answer
    – joe
    Sep 8, 2009 at 11:20
  • I have setted to display attachements inline also not working and drag and drop also not working
    – joe
    Sep 8, 2009 at 11:22
  • What happens when you use thunderbird without lightning?
    – John T
    Sep 8, 2009 at 22:41
  • Its still attachment
    – joe
    Sep 10, 2009 at 12:47
  • I'd suggest trying an old version to see if the problem persists, it can help you pinpoint which version has this bug and you can then report it to Mozilla. You can find all old versions here: releases.mozilla.org/pub/mozilla.org/thunderbird/releases
    – John T
    Sep 10, 2009 at 17:31

Could it be that something has changed on your manager's side? I believe this option needs to be selected in Outlook 2003:

Tools > Options > Calendar Options... > When sending meeting requests over the Internet, use iCalendar format

  • 1
    Manager's they never change any thing ;)
    – joe
    Sep 8, 2009 at 15:54

I don't use lightening (unless it installed automatically with thunderbird 3) but I use outlook, and i find that Thunderbird thinks .ics files are text files and cannot handle them properly. If I tell it to open with outlook it opens an email with the file attached to send. The only work around I have found is to save the attachment (I do it to desktop) then open it, and windows knows what to do with it.

why cant the programmers either let windows handle attachments like it used to in the old versions, or allow the user to add file types so that it knows .ics is an outlook calendar file (in my case)?.


I am using Thunderbird 3.0.10, and Lightning 1.0b2pre. When I receive an Outlook email invite I see a meeting.ics attachment, which can be viewed (and that's all) by checking View->Display Attachments inline.

In order to get these into my Lightning calendar, I have to save the attachment, then use Events and Tasks->Import and choose the saved meeting.ics. This works! I can then open the event, update it, and once it's in the calendar I even see the buttons accept, etc.



For as long as I have used the Lightning addon for Thunderbird, that has been the behavior. Meetings don't get automatically added to the calendar. When they are accepted they are added.

The .ics file has always been an attachment. Thunderbird may render that fact differently depending on the plug-ins you have installed.

Not the answer you're looking for? Browse other questions tagged or ask your own question.