26

I would like to merge 2 tables together in Microsoft Word. I have attempted to do the usual drag and drop, but I'm out of luck!

enter image description here

I don't know if my mouse is the problem, but even if I use the touch pad I can reproduce this issue.

23 Answers 23

19

From allexperts.com:

There are a few things you can check on:

  1. Make sure that the second table doesn't have any rows marked as heading rows.

  2. Make sure that neither table is wrapped (wrapping should be set to None on the Table tab of Table Properties).

  3. Make sure that neither table (even if they appear identical) is nested in one large cell of a containing table (this sometimes happens with material pasted from the Web).

That said, I can tell you that I once had two tables--which I had created myself, so I know there was nothing unusual about them--that just refused to merge, for no apparent reason. It's possible that the table structures were somehow damaged, and if I'd been doing this in Word 2003, perhaps using Open and Repair would have fixed the problem. As it was, it wasn't vital that the tables be actually part of the same table, so I shrugged and moved on.

If you encounter such a situation, you have really only two recourses (if Open and Repair doesn't help):

  1. Add rows to the first table and copy/paste the content of the second table into them.

  2. Convert both tables to text, then convert all the text back to a single table.

Sorry I can't be more definitive, but this is a mystery to me, too!

Suzanne S. Barnhill
Microsoft MVP (Word) 1998-2006

  • 1
    this just shows how sometimes, things are made to be complicated – Vass Feb 14 '13 at 10:59
  • 1
    Just select the table, and go to Table properties, Text wrapping should be none...It works for me. to do Shift + Alt + Down/Up arrow... – Arpit Parekh Dec 19 '15 at 16:08
  • Upvoted because I had the same issue and fixing text wrapping was what did the trick for me. – Kelly Tessena Keck Sep 15 '17 at 14:07
29

Quite often you’ll find that you have two tables in a Word document and you want to join the two together to make just one table. The solution is simple but way from obvious.

To do this, first select over all the cells in one of the two tables. If the table is underneath the one you want to join it up to, then press Alt + Shift + to move the table up the document so that it joins the bottom of the table before it. Keep pressing the key until the top row that you have selected joins the bottom border of the one above.

If you have selected the topmost table, then press Alt + Shift + until the top table locks onto the table below.

You can also drag one table up or down until it joins but this method is very slick. It also works on a single row so you can take one row from one table and move only it to join up with another table or to become a table all of its own. Experiment with this key combination – I’m sure you will love it.

Once you’ve done this, the tables will be joined to make one single table. If desired, you can then adjust the positioning of the columns so that the columns match between the two tables – this isn’t required but you may want to do it if the columns are supposed to be the same throughout.

5

Similar situation I had was resolved by adding a blank row to the bottom of the upper table and a blank row to top of the lower table. Neither of these two new rows should have columns and both tables should be the identical width. Then, by removing any returns (blank lines) between the two tables, they should automatically join. Afterward, you can remove any unwanted rows.

3

I just had a situation where my table was breaking with the cells before the bottom of the page and leaving a blank spot at the bottom of ONE PAGE in just ONE SECTION of a 30-PAGE TABLE. I did all of the checking/unchecking that is mentioned here and at other advice boards, but to no avail.

After about an hour of beating my head against a wall I calmed down and just methodically went though every option available relating to the table and noticed that in the cell that should have been broken into the bottom of one page and the top of the next (but was instead getting moved to the next page in its entirety) had a specified height (Table Properties/Row tab). I removed it and instantly the table started breaking with the page as I had been after.

So, all that is to say - another option you should check if you're encountering a situation where one cell of an otherwise-compliant table won't break where it is supposed to - see if there's a specified height to the cell in the Row tab under Table Properties.

Good luck!

2

I found if I individually converted all the tables to text, separated by tabs using:

Table Tools / Layout/ Convert

to text then selected all the text and converted to tables using:

Insert / Table / Convert Text to table

that it worked for me.

2

When nothing else works, try the following solution (works in Word 2010):

  1. Reveal hidden formatting characters (try Ctrl-Shift-8 or Alt,H,8).
  2. Select the lower table's contents (try Alt,J,L,K,T).
  3. Click the selected text; drag it up beneath the upper table's final, external paragraph mark; and release the mouse button.
1

If you have two or more tables that you need to merge in MS Word, simply put the cursor in the blank space between them and press the Delete Key until the lower table comes up and it'll merge with the one on top. It worked for me with two identical tables.

1

Check the row height.

For Windows 10

  1. Under Tables - Layout
  2. Go to Cell Sizes
  3. Click on Row
  4. Uncheck Specify Height and in "Row Height is ..." put at least
  5. Under Options, check "Allow row to break across pages".
1

Press Ctrl + Shift + 8. This will show all the non-printing characters in the word document. Delete the paragraph symbol ¶ between the two tables which you want to combine. The two tables will be combined.

1
  1. Click on the cross-in-square at the left upper corner of the top table.

    If both tables are highlighted, it is likely that the lower table is nested in the upper table.

  2. Click on the same square for the lower table.
  3. If only the lower table is highlighted, cut it (Ctrl-X) and paste it in the non-table space below the upper table.
  4. Then proceed with the table merge strategies described by others.
  5. Once they are merged, click and drag column boundaries of one table to match the other.
0

Click the button with a symbol ¶ (mirrored black P) which shows all non-printing characters (result of various formatting). Little blue marks will appear in the text.

Find one between two tables that prevents them from joining. Put your cursor next to it and press Delete. It will go away, and the tables would stick together.

  • Just for comment, the mirrored black P is called pilcrow – Stefano Borini Oct 1 '18 at 12:13
0

As was suggested by a proficient user whose advice I found, I used the search and find using the caret p or ^p (and the caret is shift 6) to find the paragraph break between the sections.

Well, first I had to figure out how to show the search and find pane, which was under view, search. THen I had to figure out how to make the caret symbol, and finally figured that out.

Then I figured out you have to keep hitting "next" until it highlights the offending paragraph symbol.

Then, after trying a thousand other things that did not work, on the thousand and first try, I went to the edit menu again, and hit "cut"

and paragraph symbol that i did not want (that was giving me the blank space) was gone! Just like that!!!!!

0

It's quite simple: insert empty row bellow first table, cut second table, right mouse click on added row then select paste option "merge tables"

0

If all the other suggestions have failed try this :

If you remove everything between the two tables that you want to merge you will likely find that you can move your cursor between the tables and it appears that there is a blank line in between them.

I'm sure you've tried hitting backspace expecting the lower table to move up and join the one above, but it seems that the blank line just will not let itself be removed.

Instead - try the DELETE key ! This has worked for me a number of times. The blank line in between dissapears and the tables sit next to each other and appear as one.

0

I've been fighting with table styles all day then came across this problem. I had to clear formatting of both tables, then I deleted the paragraph between the tables and they merged perfectly.

0

I went to hell and back with this problem. I tried everything listed here above, and on many other forums and sites, but nothing worked. I was trying to combine two IDENTICAL tables, each copied from a separate documents, to no avail. The tables look merged, but there is always a thicker line between them and each table would still be separate.

How I fixed it in the end was quite amusing yet incredibly unsatisfying:

  • Make sure you try everything mentioned before (wrapping, style, size...).
  • Leave the two tables apart.
  • Save the document.
  • Exit the document.
  • Open the document.
  • Delete the space between the two tables.
  • The tables merged.

Whatever was messed up with Word needed only a restart of the document to get fixed.

0

In Office 2007, select the space just below or above table depending on where the other table to be inserted and right click. You should find an option "Paste by Appending Table". Just click on it ....voila !!

0

After trying all of these I finally had a brainwave. Added, I am working on office for mac, so it might be a bit different, but try this (I love how simple this ended up being!):

Drag Select the last row of the first table you want to merge together with the first row of the table underneath, go to the Edit tab and select Merge table.

hahaha... so easy, but not really intuitive. Should this be under the table tab, Microsoft? (maybe I'm missing something?).

0

The merging of table can be done using text wrapping properties.

  1. For that, select first table.
  2. Go to properties--> In table properties, select text wrapping as none and then click OK.
  3. Now select second table. do the same thing as mentioned in point No.2
  4. If there is any gap between the 2 tables, place the cursor in the gap and press delete button or if you cannot place the cursor in between, place the cursor in the last row/ cell in the first table and press delete button.

And now the 2 tables become combined.

0

select last row of upper table and first row of below table, then go to layout option nd click on distribute rows

0

Save the document as an older version of Word, i.e. Word 97-2003. This will allow you to merge the two tables simply by deleting the ^p (paragraph/return) symbol.

This worked for me after trying everything above without success.

You can convert the document back to your current version of Word by 'Save As'.

0

I have been using tables for many years, and this has been comparatively trouble-free. However, just recently I discovered that one of my files could not be put into alphabetical order. At first I was puzzled and, thinking that I had made some kind of mistake, tried several times to fix the problem, but to no avail. Then I tried selecting the table and, upon scrolling down, I discovered that the whole table had not been selected. The shading stopped at a line which was thicker than the boundaries between the other rows, as mentioned before on this list. In this way I discovered that what I thought was one table consisted in fact of three tables, each with its little box with the cross marking the beginning of that table, but with no space between them. I then noticed that the 2nd table had only two rows! This apparent anomaly attracted my attention. Could these two rows have been imported from another file, perhaps a file composed in a different version of Word? With this in mind, I went to the last row of the 1st table and inserted two new rows below it (by pressing ‘return’ and then F4 to repeat the action). I then selected the two rows of the 2nd table, picked them up using Ctrl + x, and then selecting the two new empty rows, dropped what I had picked up into them. This left two empty rows which I then deleted. By using ‘select table’ I found that I now had one table, which I could now put int alphabetical order!

0

Inert a blank row at the bottom of the upper table. Define all cells of the bottom table. Place your cursor at the top-left corner of the upper-left defined cell of the bottom table. Press the left mouse button and, holding it down, slide it up into the left inserted cell at the bottom of the upper table. Boom.

protected by Ramhound Feb 9 at 4:25

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.