A while back I decide to create a couple of Windows Image Backups of my workstation at various points during installation from clean.

While doing this I decided to rename the folders containing the VHDs from 'Backup <Date>' to something else of my choosing.

I didn't bother testing at the time that the restore still worked.

Now I come to use these backups for doing a bare metal restore to a different computer.

The problem is restore cannot 'see' any of the backups.

So I have deduced that maybe I need to rename them back to the 'Backup <Date>' pattern unfortunately I cannot determine the exact values that would have originally been used here. I have tried by best guest but the images still cannot be found. I have tried doing both a network and a usb hdd restore. No luck on either.

P.S. I know I can retrieve files from within the VHDs, the problem is I am trying to save myself time of reinstalling lots of big applications... not trying to recover data.


Not sure exactly what is going on so forgive me if I ill advise; I use Acronis for back-up not windows; that said it would be my understanding that the would just be a system date for GUI perposes so that you can choose which one from the list any date should work in the proper format if this is correct;

In order to get an idea of the format you could creat a new back-up and copy that formatting over to the old back-ups with a reasonably correct date; there maybe some reg key changes also so you may want to check that.

If that doesn't work there is a slim chance you could use proprietery back-up software like Acronis (no plug intended) which might be able to 'read' your files: Acronis allows a conversion between Acronis to Windows and back again.

Hope this helps?!

| improve this answer | |

This is what I have discovered so far:

The following changes will cause the backup not to be recognised (I am testing using wbadmin get versions -backupTarget:D: )

  • If you delete or modify the MediaId file from the root
  • Delete or modify the Catalog/GlobalCatalog file (deleting the BackupGlobalCatalog seems to have no effect)
  • Rename the Backup <Date> folder to anything else (I tried changing it by 1 second)
  • If its not inside D:\WindowsImageBackup\<PC-NAME>\ folder (in my example)

You can delete the SPPMetadataCache directory and it appears to have no effect - backup is still recognised.

So, the essential parts so far are MediaId, GlobalCatalog, the dated folder and presumably its contents.

To be continued...

Update: MediaId contains a reference into the GlobalCatalog file...

Update 2: I am going to try brute forcing this using a powershell script...

Update 3: Well I found the correct folder name using a painfully slow powershell script:

#must match the starting date of the folder
$date = Get-Date '15/10/2010 00:34:24 AM' 
$nextDate = $date.AddDays(1)
cd "D:\WindowsImageBackup\My-PC\"

$dateString = Get-Date $date -format "yyyy-MM-dd HHmmss"
$nextFolder = "Backup $dateString"
while ($date -le $nextDate)
    $nextFolder >> out.txt
    wbadmin get versions -backupTarget:d: >> out.txt

    $folder = $nextFolder

    $date = $date.AddSeconds(1)
    $dateString = Get-Date $date -format "yyyy-MM-dd HHmmss"
    $nextFolder = "Backup $dateString"

    ren $folder $nextFolder

Just search inside the out.txt file until you see the word 'target'.

| improve this answer | |

I found the original PC name, and therefore the original name of the subfolder under WindowImageBackup by looking in the SPPMetadataCache folder. There is a file in there which if you open with Notepad you will see the original name nestling near the start among lots of other data. However... it's not completely obvious so this assumes you have some idea what it was orignally called.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.