For 3 days now I've been unable to boot into my Windows 7 partition, and all my research has been to no avail. I'm hoping someone here has more ideas on how to fix this.

When I boot up now, I get the black screen with BCD error that says theres no valid file system or it may be corrupt (pardon my lack of detail, no copy/paste is available then).

When I boot with the Windows 7 disc and go into repair tools, no operating system is found, and attempting to automatically repair the problem fails with Unknown Operating System (Unknown Disk) or something similar. When I drop into the command prompt, I am able to see and navigate my C:\ drive without issue.

I attempt to use bootrec:

C:\> bootrec /ScanOS

Finds C:\Windows as a system partition.

C:\> bootrec /RebuildBCD

Fails with volume does not contain a recognized file system. please make sure that all required file system drivers are loaded and that the volume is not corrupted.

So then I attempt to fix the bootsector:

C:\> bootsect /nt60 C: /force

Which completes successfully (sorry, no output..)

Upon rebooting, I have the same problem.

I've also tried all of the above after making my Windows partition active:

C:\> diskpart
DISKPART> select disk 1
DISKPART> select partition 1
DISKPART> active

Then bootrec as above, both with and without a reboot after the DISKPART commands.

Then I've also tried rebuilding the BCD store by hand:

set systemdrive=C:
set tempbcd=C:\boot\bcd.temp
set tempfile=C:\boot\temp.txt

bcdedit -createstore %tempbcd%
bcdedit.exe -store %tempbcd% -create {bootmgr} -d "Windows Boot Manager"

bcdedit -store %tempbcd% -create -d "Windows Vista" -application osloader>%tempfile%
set /p winvistaguid= <%tempfile%
set winvistaguid=%winvistaguid:~10,38%

bcdedit -store %tempbcd% -set %winvistaguid% osdevice partition=%systemdrive%
bcdedit -store %tempbcd% -set %winvistaguid% device partition=%systemdrive%
bcdedit -store %tempbcd% -set %winvistaguid% path \Windows\system32\winload.exe
bcdedit -store %tempbcd% -set %winvistaguid% systemroot \Windows

bcdedit -import %tempbcd%

However on the import, I get my familiar friendly message:

volume does not contain a recognized file system. please make sure that all required file system drivers are loaded and that the volume is not corrupted

I'm at my wits end here, and I cannot understand why Windows refuses to see this as a valid install.

When I list the disk/partition in DISKPART, it shows up as NTFS and "Healthy", and I can navigate the directory structure from DOS with no problems.

I really, really do not want to reformat and reinstall. I know this problem can be solved!

6 Answers 6


I solved the problem using diskpart to fix the apparently 'corrupted' filesystem ("... does not contain a recognized filesystem") and then recreating the BCD using bootrec.

C:\> diskpart
DISKPART> select disk 1
DISKPART> select partition 1
DISKPART> active
DISKPART> extend filesystem
C:\> bootrec /rebuildbcd

Be sure to run chkdsk /f after booting to Windows.

I also suggest looking at the EasyBCD program. I have not tried it myself but it looks promising.

Just for the record, I had increased the size of my NTFS partition using Gparted, that's why I used extend filesystem in diskpart.

  • 2
    It worked for me after shrinking NTFS partition with gparted. It turned out the patition was "inactive" after shrinking, and all the magic was in the "active" command. Then I had to run "repair" from Win CD twice (yes, twice) and I'm back on windows. Nov 20, 2011 at 8:30
  • It worked for me, thanks! But first I had to shrink the partition inside diskpart, i.e.: DISKPART> select disk 1 DISKPART> select partition 1 DISKPART> active DISKPART> shrink DISKPART> extend DISKPART> exit
    – Luca
    Apr 1, 2021 at 11:53

I had the same problem, I tried exactly the same solutions, and it didn't work.

Then I tried disconnecting all my other hard drives, leaving only the one with my Windows installation on it. I rebooted with Windows7 recovery disc, and ran the automatic repair, it recognized the drive and the windows installation (until I disconnected all my other drives the "System Recovery Options" list was always empty), and it said there was an error with that volume, and that it was successfully fixed.

I rebooted again, ran automatic repair again, and voila, everything was fixed and I was back in Windows.

  • 2
    I have no idea why, but this worked for me too.
    – Fambida
    Jan 26, 2012 at 9:14
  • I experienced this too. This may have to do with Windows only recognizing the primary drive issued by the BIOS. This is a common problem when installing windows, too. It's very likely that the OP had this issue, too. To fix this, one can simply select the Windows drive as primary in the BIOS and let Windows fix itself.
    – nemo
    Sep 15, 2012 at 11:48
  • 3
    Disconnecting everything solved my problem too, thanks!
    – Joril
    Apr 29, 2013 at 13:12
  • When i run the windows usb installation to repair the boot error it didn't list my windows installation. I went to the bios settings, set my windows disk in the second plaec in boot order (USB/windowsDisk/LinuxDisk... before i got USB/LinuxDisk/WindowsDisk). Boot from usb again and this time my windows installation was listed and boot was automatically repaired Mar 12, 2016 at 18:57
  • Wow thanks! Same here, i moved my c partition with gparted, and got 0xc0000225 and volume not recognized with rebuildbcd. Disconnecting my extra, unrelated harddrive allowed windows 10 startup repair to fix the bcd instantly.
    – J.A.K.
    Oct 21, 2017 at 17:51

Unfortunately, none of these answers worked. After 10 days of trying everything I could find and think of, I wiped the drive and reinstalled Windows.

  • 1
    Thank you for posting back, even though your problem wasn't actually solved.
    – oKtosiTe
    Feb 25, 2011 at 20:18
  • Just wondering, did you have any other hard drives at that time, (apart from the one with your windows installation of course)?
    – ArtBIT
    Jan 26, 2012 at 17:50

I just had this same issue, which lasted for weeks. For whatever reason I decided to shrink Windows 7 and grow Ubuntu 10.10 using GParted.

Anyway, I followed the same steps you followed over and over again. The trick (and the fix for me) was after setting the partition active, also run RESCAN. Then, exit and run bootrec /rebuildbcd. For good measure I also ran the GUI boot fix. After a reboot, I was back in Windows.


Back up your data and run a chkdsk on the drive, it this does not get it bootable use a utility such as Spinrite or HDD Regenerator on the disk

  • Ah, forgot to mention I ran "chkdsk /R" yesterday, to no avail. Feb 4, 2011 at 22:09

This may or may not work, but I've had the same problem and found that by installing a second Windows 7 system on the same drive but separate partition will allow you to boot up and run your bcdedit program and add or repair the boot manager to the first Windows 7 system.
Also use the second Windows 7 system to scan and remove any viruses.

Not the answer you're looking for? Browse other questions tagged or ask your own question.