While trying to load the website at wizzair.com, all the browsers I tried fail with a timeout.

Every other website I've tried loads normally.

This problem appeared "out of the blue" (no changes of the settings of either my computer or router) and has been going on for more than a week (I'm not exactly sure when it started).

My network setup is the following: All computers are connected to the same router (a D-Link DIR-600). Some have static IP and some use DHCP. The router is connected to a cable modem (given by my ISP).

The problem is present on all computers inside my home network, regardless of how they're connected (wifi or ethernet).

My phone will load the website without problem if connected through 3G but will fail when connected to my home wifi.

The same website will load fine from a different internet connection.

If I connect my computer directly through the modem (no router), the website loads.

Other diagnostic tests I ran:

  • ping domain.com: 0% packet loss (the DNS resolution is correct too)
  • telnet domain.com 80: timeout
  • traceroute domain.com: log here

Steps I tried to fix the problem:

  • Tried different browsers (Firefox, Chromium, w3m);
  • Replaced the firmware on my router with DD-WRT (I had the factory one);
  • Changed the MTU value from 1500 to 1492 in my router admin panel (following a suggestion I found online);
  • Placed my computer in my router's DMZ.

None of these steps had any impact on the problem.

I also tried to change the MAC address of the router but after doing so, my router would not acquire an IP from my ISP anymore. This might not be related to the problem at hand since it's most likely caused by my not being able to use the new DD-WRT firmware properly.

Does anyone know what the problem might be or what other tests I could run to further diagnose?


2 Answers 2


If you can load the site through the modem without the router, try going into the admin panel of the router and cloning your PC's MAC address. If this works, they are filtering your MAC address for some reason like Sinrai suggested.

  • Good suggestion - should have thought of that myself! Doh.
    – Shinrai
    Feb 4, 2011 at 20:42
  • This time I managed to set up the router's MAC address to be my computer's. I'm not sure what I was doing wrong previously, but it worked this time. And it did fix the issue. To be sure, I reverted the router to its original MAC address and sure enough, the website stopped loading. Feb 4, 2011 at 23:11

Are you sure that the site is actually responding normally when this is happening? This sounds like a problem on THEIR end...even though your phone can hit it, it could be a server issue. I'd contact the webmaster before I'd do anything else and ask if it sounds like a problem that could be their fault. They might be filtering your MAC for some weird reason, for all you know.

EDIT: And what @horatio said in the comments.

  • 2
    contact your ISP as well.
    – horatio
    Feb 4, 2011 at 18:10

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .