7

I want to Bridge my Windows 7 laptop's wireless and wired adapters. I just select my ethernet and WIFI adapter, and choose create bridge.

However when plugging in ethernet cable, instantly my WIFI disconnects. How to prevent this?

I have a HP nx6310 laptop with latest WIFI drivers.

8

I found this on another website and it worked for me:

"When more than one network connection is available, Windows uses the one with the lowest metric value. By default, it automatically assigns a metric value based on the network connection's rated speed. See An explanation of the Automatic Metric feature for Internet Protocol routes .

To force Windows to use a specific network connection, assign a metric value to each one, giving the lowest value to the desired connection:

  1. Open the Network Connections folder (Start > Run > ncpa.cpl)
  2. Right click the desired connection.
  3. Click Properties > Internet Protocol Version 4.
  4. Click Properties > Advanced.
  5. Un-check "Automatic metric".
  6. Enter a number between 1 and 9999 for the "Interface metric"."

http://answers.microsoft.com/en-us/windows/forum/windows_7-networking/wired-and-wireless-connections-on-the-same-windows/ee40d9a6-297b-46d4-b5c8-db57d927b62e

2

Some computer have a setting in the BIOS that disconnects WiFi when an Ethernet connection is present.

Or if you have the HP utilities installed check for this setting in Windows.

2
  • 1
    Sorry but it is nonsense.
    – peterh
    Apr 5 '16 at 14:20
  • 1
    @peterh Actually, it's not. A lot of Dell laptops are configured like this right out the gate; especially for business needs. There is a script that can be run while booted into Windows to fix it or go into the BIOS and do it, manually if you have the access privileges.
    – Erutan409
    Nov 3 '16 at 15:53
1

Are you trying to hook a PC with no internet connection up through your laptop with the bridging built into Windows? I've done itin XP, but not needed to in Win 7 yet. It should still work though.

Many laptops have settings to automatically disable the WiFi chipset when a connection is made on the Ethernet port. It's done as a power optimization because normally you don't want to use WiFi if an Ethernet connection is available. You'll have to disable that before this works. Different vendors put settings in different places. Check the BIOS, Device Manager (properties of WiFi), or any vendor supplied power managers or optimizers.

0

Although OP is using HP, I am adding this answer for Dell (Latitude and Precision) owners who might come across the same problem.

Dell stations have "Automatic Disabling of Wireless when a Wired Connection is Detected" option in BIOS. Before sharing connection or creating a bridge, go to BIOS (press F2 or F12 during computer restart) >> Power Management >> Wireless Radio Control and make sure that Control WLAN radio option is NOT checked.

-1

Windows 7 will instantly disconnect the Internet and reconnect when a better connection presents itself. However, the wireless adapter should still be enabled and available.

If what you want is to use both connections in parallel in order to speed-up Internet transfer, then this is not possible. Windows 7 will always only ever use one connection.

If you wish to use your computer as a bridge for another computer to connect to the Internet, see this article : Turn Your Windows 7 PC Into a Wireless Hotspot. But just be prepared for a low bandwidth.

7
  • 1
    I actually want to connect to internet with my desktop throught my notebook wifi. So i don't want to create hostpot, but create a bridge between wifi and ethernet interface on my laptop. Feb 7 '11 at 8:10
  • The hotspot is the bridge you are looking for. Otherwise, you need another router.
    – harrymc
    Feb 7 '11 at 8:48
  • 1
    Oh, i think we have a misunderstanding in between. My desktop doesn't have a wifi, so he cannot connect to laptop. But instead i want: PC <--Ethernet-->Laptop<--WiFi-->Router NOT (as article says) PC <--WiFi-->Laptop<--Ethernet-->Router Feb 9 '11 at 7:56
  • Have you checked that connection sharing is off on both wireless and wired before bridging? If you cannot bridge them, one solution to the problem is by getting a wireless dongle for the desktop.
    – harrymc
    Feb 9 '11 at 10:22
  • any fix? I am having the same problem with the WiFi disconnecting as soon as the wired connection appears.
    – Alexis K
    Apr 8 '11 at 15:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.