1

This morning I ran the Repair Permissions command from inside the Disk Utility. Ever since then my MacBook wont move past the splash screen when booting.

I've revolted in verbose mode and I see that it is trying to repair the disk but then terminates with 'Unable to repair the volume'.

Since then I have tried running the Disk Repair from the Snow Leopard install DVD and it quits with the same error. Is there a way I can repair this thing without reformatting and installing over again?

How does something so simple as a permissions repair make the system unbootable like this?

0

If Disk Utility is unable to repair the volume then this means either the hardware itself is damaged or the directory (not like a folder in this case) is damaged beyond what Disk Utility can fix.

I'd highly recommend getting a copy of DiskWarrior which excels at fixing these kind of errors while keeping the data intact.

If DiskWarrior is unable to fix it, then your best option is to reformat the drive and reinstall Mac OS X on it after checking the hardware.

How does something so simple as a permissions repair make the system unbootable like this?

If something occurs during the permission repair (just as with any read/write action) that corrupts the disk's directory it can happen quite easily. Usually this happens when there power or connection to the drive is cut suddenly during disk I/O.

Also, is there any specific reason you were repairing permissions?

  • DiskWarrior couldn't do anything, so I ended up formatting and reinstalling OSX. Since you're the only one that mentioned that option, the points are yours, thanks! – Power-coder Feb 15 '11 at 12:33
  • You probably could have fixed it without re-installing but once you got it booted you would have probably still had problems on your disk. There are various different ways to run fsck or fsck_hfs and if you don't do it exactly right, it won't work. Also, DiskUtility can't fix some things but in my experience you can always at least get it booted. – djangofan Sep 30 '11 at 15:03
0

I would try running Apple Hardware Test or Techtool Deluxe (if you have AppleCare) and see what the result is.

  • The hard drive is working fine, I can boot into my Bootcamp partition just fine, it's just osx that won't boot. – Power-coder Feb 5 '11 at 19:52
  • The part of the disk where bootcamp is may be fine, but you could have bad sectors on the os x partition. I would test the disk to at least eliminate it. – Chris Feb 5 '11 at 20:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.