I'm running VirtualBox on a Win7 host. Guest OS is Centos. My setup is a laptop (screen 1) with a huge external monitor (screen 2). I'm only telling Centos there is one monitor though.

When I start up VirtualBox on screen 1, the mouse capture works fine. I don't have mouse integration because (I think) the kernel on Centos is too old to support it. That's fine, I don't mind doing the Right-Control thing.

The problem I have is that when I drag the whole VM window over to my second monitor, the mouse capture doesn't work right anymore. I click inside the VM and can move the VM cursor a little bit, but I can't always get to the edges of the VM screen -- before I get all the way to an edge, the cursor will escape from the VM as if I had hit right-control. But it's still captured according to the icon, and if I then hit right-control, the guest cursor jumps to a different screen location.

My workaround: if I have the VM window mostly on screen 2, but a small corner of it still on screen 1, then the mouse capture works correctly.

Is there a setting to make this work better?


I run CentOS on Virtualbox, on a 64bit version of Windows 7. Guest Additions worked fine for me. I followed some simple instructions to make sure the kernel-headers and kernel-dev packages were installed. The Guest additions are supported starting with RHEL 3.

| improve this answer | |
  • Thanks for solving my problem instead of answering my question!!! I could swear I tried those same steps a week ago and got some error message about how it couldn't compile one part of the guest additions. Worked fine today. – Dan Feb 7 '11 at 15:31

The mouse bug you described is known, but not assigned. For all who want to stay informed: Guest mouse malfunctions in multiscreen environment

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.