I have 3 Vista PCs in my office which won't download Windows Updates, either automatically or manually. When I click on "Check for Updates", I get the message "Windows could not search for new updates", error code 80072EFD. I have tried the suggestions in the Help and KB articles which the error links to (mainly regarding firewalls and antivirus software), but to no avail. I suspect there is some setting on my server (SBS2003) which is preventing these updates, though all the XP machines on the network have no problem with updates, only the 3 Vistas. Any thoughts on where I might look for a setting which might be causing this problem? These PCs have not been able to be updated since they were first added to the network 2 years ago (though I didn't notice it till about 6 months ago, and have been trying to solve it since then). Thanks!

  • SandyU, could you update your post with what you've tried so we don't tell you the same things? – hyperslug Aug 18 '09 at 12:58
  • I am working (as I have time) on looking at the suggestions I've received so far. I'll let you know the result. – user5793 Aug 18 '09 at 16:36

This frequently happens on some machines when Microsoft changes service packs.
I never understood why it happens, but the solution is quite simple.

The solution is to download the Standalone version of vista service pack 2 and install by hand. After the installation, Windows Update will start functioning again.

If google is not playing me false, the download location is here.

| improve this answer | |
  • I had this same issue on windows 7 SP1, after trying al the other suggestions here to no avail I uninstalled SP1, then installed it again and now updates are working. Thanks for the tip. – mockobject Jun 23 '11 at 18:56

Microsoft has a KB article that describes this error as well as several more. It is KB 836941 You may encounter temporary connection-related errors when you use Windows Update or Microsoft Update to install updates . There are seven possible resolutions, so you may need to try each one until it is resolved.

For your information, the KB discusses the following Windows/Microsoft Update errors:

  • Error 0x80070008
  • Error 0x800705B4
  • Error 0x8007000E
  • Error 0x80072EE2
  • Error 0x80072EFD
  • Error 0x80072EE7
  • Error 0x80072EEF
  • Error 0x80072EFE
  • Error 0x8024400E
  • Error 0x80072F76
  • Error 0x80244016
  • Error 0x80072F78
  • Error 0x80244022
  • Error 0x80090305
  • Error 0x8024402F
  • Error 0x8009033F
  • Error 0xC80003FA
  • Error 0x80244008
  • Error 0xC800042D
  • Error 0x8024400A
  • Error 0x80071A90
  • Error 0x8024400D

These errors may occur caused by any of the following issues:

  • Applications or processes that interfere with Internet communications
  • Resource issues on your computer
  • Too much activity on the update site
  • High Internet activity
  • Recoverable database errors
  • Server time-out issues on the Windows Update or Microsoft Update site
| improve this answer | |

80072EFD. Hmm...

Go into the registry on the Vista machines and check the value of the registry key UseWUServer in HKEY_LOCAL_MACHINE\Software\Policies\Microsoft\Windows\Windowsupdate\AU.

Is it 1?

If so, set it to 0 and restart.

A forum thread on this very problem can be found here.

| improve this answer | |

I had the same issue

enter image description here

To fix this I opened the update log located at


There I found

WARNING: SendRequest failed with hr = 80072efd. Proxy List used: 
         Bypass List used : <(null)> Auth Schemes used : <>

And then I remembered I had Fiddler installed. Fidler is used as local proxy to display HTTP traffic, so when it wasn't started, the proxy server effectively didn't work and that prevented Windows from downloading updates. To add more confusion, I was able to access websites and manually download things from the local browser. It's only automated stuff was not going through and I misinterpreted this as some sort of malware.

I fixed Fiddler by unchecking the proxy checkboxes

enter image description here

| improve this answer | |

I've had the same problem as you with Vista Business. It happened after I had just reinstalled Vista. I did the updates that were available; after that, it just kept saying "Windows could not search for new updates".

The solution to my problem was installing a fresh copy of Vista Business and installing SP1 manually (or just try to find a DVD with Vista already patched).

| improve this answer | |

Last time I saw this problem, it was due to the Conficker worm. Do the other MS security elements work fine? I don't know, Conficker might be quite irrelevant by now, but run this simple check: Conficker eye chart

| improve this answer | |

I'll suggest you to follow a REPAIR INSTALL, as soon as possible, this tutorial proved all its valor many times and i've used personally for our "fragile" Vistas.


"Litte off-topic" If you are responsible of your office LAN you are taking needless risks leaving this pcs without updates and linked to the net for so long especially if we seen the huge quantity of bugs viruses and vulnerabilities developed and discovered during these 2-3 years, that kind of errors may cause a lot of problem to your company and yourself.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy