I have a truecrypt volume on a hard drive. When I try to mount the volume from the hard drive I get an error with Incorrect password or not a truecrypt volume. If I copy the truecrypt volume onto my local hard drive and then mount it, it works fine.

Any ideas?

  • I got this error when the password was incorrect – Matthew Lock Aug 19 '13 at 5:43

I used to get this same problem and searched the net and tried everything others had. I was on a Lenovo 64 bit laptop (T410) running Windows 7. I had a separate logical drive and was encrypting the entire drive. The HDD on my laptop is a 500gb, 150 odd for my C drive and another 350 odd for my X drive. I encrypted my entire X drive (logical drive).

True Crypt was working fine and then suddenly one day after using it for about a month, it just would not mount and kept telling me the password was wrong (the password was not wrong). I actually deleted the partition and started all over again. And it worked fine for a few days and then i had the same issue again.

anyway i tried everything but eventually i got it working by changing my drive letter for the mount.

I suspect that something i installed was locking up the partition so when i changed the drive letter from x to s it suddenly started working again. I changed this in My computer, Manage, Disk Management, right click on the drive and then change the drive letter.

Hope this helps others who may have had the same issue.

| improve this answer | |

Had this problem a few minutes ago on a 465 GB fully encrypted secondary drive. Obviously "formatting and starting over again" was not an acceptable solution. The following troubleshooting documentation describes this problem as relating to a corrupted volume header.

My guess as to why mine got corrupted is that I was doing some MBR work using Hiren's BootCD on a USB drive after removing a Ubuntu partition from my primary drive and may have somehow inadvertently touched the secondary drive's headers.

After restoring the volume header from the backup embedded in the volume, I've been able to mount and regain access to the volume. Steps are shown below taken from TrueCrypt's website.

See http://www.truecrypt.org/docs/?s=troubleshooting


TrueCrypt volume cannot be mounted; TrueCrypt reports "Incorrect password or not a TrueCrypt volume".

Possible Cause:

The volume header may have been damaged by a third-party application or malfunctioning hardware component.

Possible Solutions:

If you created your volume using TrueCrypt 6.0 or later, you can try to restore the volume header from the backup embedded in the volume by following these steps: Run TrueCrypt 6.0 or later.

Click Select Device or Select File to select your volume.

Select Tools > Restore Volume Header.

If you created your volume using TrueCrypt 5.1a or earlier, you can try to mount your volume with the command line option /m recovery as follows: Install TrueCrypt 6.1 or later.

On your keyboard, press and hold the Windows key and then press R. The Windows Run dialog should appear.

Type in the following command (replace the last argument, \Device\Harddisk1\Partition0, with the path to your volume and if TrueCrypt is not installed in %ProgramFiles%, replace %ProgramFiles% with the path to TrueCrypt):

"%ProgramFiles%\TrueCrypt\TrueCrypt.exe" /q /m recovery /v \Device\Harddisk1\Partition0

Press Enter to try to mount your volume.

| improve this answer | |

Is the truecrypt volume a file? If it is, when you mount it from the hard drive it might think you're trying to mount the entire partition, instead of the file. Make sure you're selecting the actual file and not just a full partition.

| improve this answer | |
  • Thanks, but I'm not trying to mount the disk. Only the truecrypt volume file. – Michael Shnitzer Feb 9 '11 at 16:34

I fixed this in 15 minutes with a system restore... I don't especially trust the volume anymore, so I would recommend extracting your data, then create a new one.

I hope that helps!!!

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.