This is something of a continuation of this question.

I am now completely unable to boot this computer. The last time I used it, I used hibernation mode. When I needed to use it again, it would not respond at all to the power button, keyboard, or mouse.

I tried:

  • Holding down the power button for 15 seconds
  • pressing the power button
  • Unplugging the power cord for 30 seconds, plugging it back in, and trying again
  • Removing the motherboard battery for over a minute and reinstalling it

Before removing the motherboard battery, none of the lights on the front of the computer lit up. After reinstalling the battery and plugging the power cord back in, the light behind the power button is constantly illuminated (without even pressing the power button), but there is still no response to the power button, no fans turned on, nothing else that would indicate that it is running.


Acer Aspire ASE700-UQ660A (Specs should be all factory defaults except:) 4 GB RAM Nvidia GeForce 8600 GT with driver version 197.45

Windows 7 Professional 64 bit

  • How old is this laptop? It may be time to get a new one (preferably from a better brand). – MBraedley Feb 10 '11 at 11:44
  • Not a laptop, about 3 years old I think, and the problem was the power supply. Replacing it seems to have fixed it. – Tim R. Feb 16 '11 at 11:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.