I tends to get this problem from time to time. The tooltips with a shadow appearing on top of everything. It's the shadow of the tooltips not disappearing after the tooltips disappear. The last one I had the tooltips was from the wifi connection list at the systray.

This problem also happen to me on another computer. Both running Win7 with ATI gpu.

I found this similar post Menu command stuck on screen but none of the solution helped. In fact the "Fade or slide tooltips into view" has been unchecked from the beginning.

Ending task of "dwm.exe" also doesn't help. So far the only way to resolve this by restarting window.

I can't post picture yet, so can't show any screenshot.

Edit: Just tested a few more trick which doesn't work.

  1. Turn of aero
  2. Hibernate
  3. Switch main display to external display and switch back.
  4. Change resolution

Edit(heavyd): Here is a screenshot from my machine. Shadow

  • heavyd: Yap, that's what i get also, it happen like almost all the time if I have my pc running long enough – faulty Mar 19 '11 at 6:41
  • have you tried updating your video card drivers or switching to basic theme and then back? Also have you tried disabling drop shadows here is a link to another question about disabling them superuser.com/questions/113804/… – Riguez Mar 19 '11 at 7:14
  • Haven't tried video card driver. But changing theme doesn't work, I tried change no windows classic and back. – faulty Mar 25 '11 at 15:33
  • 1
    This is how I resolved it. I am using Windows 7 Ultimate. Go to Control Panel > Change Theme. Set the theme to High Contrast White. The ghosted menu should go away. Set your theme back to what it was. – H A Jul 11 '12 at 17:03

First a remark : Instead of restarting Windows, one can just restart Explorer. In the Task Manager, kill explorer.exe, then restart it using the menu entry File / New task.

A sure way to solve the problem is to simply disable shadows on tooltips :

  1. Start Control Panel -> Ease of Access Center, or just press Windows logo key+U.
  2. Under "Explore all settings", click "Make the computer easier to see".
  3. Under "Make things on the screen easier to see", click "Fine tune display effects".
  4. Click the "Effects" button.
  5. In Effects, uncheck "Show shadows under menus".
  6. OK all the way out.
  • 1
    Tried restarting explorer, doesn't help also – faulty Mar 22 '11 at 12:50
  • @faulty: (astonishment) Do you mean that restarting explorer doesn't redraw the desktop ? – harrymc Mar 22 '11 at 13:01
  • 2
    On both my Windows 7 machines, clicking "fine tune display effects" opens up the Personalization control panel. I can't seem to find any way of changing effects from there, and searching the control panel doesn't yield anything useful, either. How else can you reach the setting? – Paul Lammertsma Sep 30 '11 at 9:15
  • 1
    @Paul: Control Panel -> System -> Advanced System Settings -> Advanced tab -> Performance / Settings -> Visual Effects tab. In effect, "Show shadows under menus" has disappeared (!), but you might try turning off other effects. – harrymc Sep 30 '11 at 9:42
  • 2
    I had taken a look at that list, but toggling the other shadows (windows and cursor) had no effect. I ended up resolving the lingering shadow for now by switching color depths back and forth. – Paul Lammertsma Sep 30 '11 at 10:01

instead of change resolution, can you try change color depth, and see if it works? Once the shadow is gone, you can just say "no" to the new color depth.

  • This worked perfectly. Changing resolution or toggling shadows did nothing. – Synetech Jun 19 '15 at 18:14

If I remember correctly, there was an options in the windows performance settings to disable tooltip shadows.

  • 3
    I did turn it off after the incident, it doesn't help remove the stuck shadow. But i would prefer to solve the problem rather than work around it. – faulty Feb 13 '11 at 11:36

I believe I solve this each time by getting it to appear again, from the same program: It causes the previous one to disappear.

  • I think it doesn't help, but I'll try when it happen again – faulty Mar 19 '11 at 6:43

According to this documentation of a similar program that had the bug:

  • The owner of the program has to correct this issue.

    I can confirm this, for me, Process Explorer is the only program has this issue.

  • You can workaround the problem by disabling the menu shadow.

    • Right click My Computer.

    • Select Properties.

    • Go to the Advanced tab.

    • Click the Settings button in the section labeled "Performance".

    • Disable Show shadows under menus.

  • Alternative: Get a tool to quickly switch resolutions/bit depths, or run one or another DX/OpenGL demo.

  • 1
    "switch resolutions/bit depths, or run one or another DX/OpenGL demo." doesn't work for me – faulty Mar 22 '11 at 12:51
  • 1
    I wish I had the guts to track the API call to the shadow and write up a hook/hack to fix this, maybe somewhere in the far future I will be able to... – Tamara Wijsman Mar 22 '11 at 12:52

protected by Community Nov 11 '11 at 22:57

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.