Apologies in advance, this is going to be a long story ;)

Today a friend brought me his computer to fix because it no longer boots, it freezes up while the Windows 7 logo and "starting windows" is still on screen. For what it's worth, it's an HP Slimline, not sure exactly which model.

First thing I did was try to boot in safe mode, this showed the computer hangs while or just after loading DISK.SYS. This is the last line safemode shows before it stops responding.

Second since the computer is fairly new I tried reinstalling Win7 from the CD. This also hangs while "starting windows". Trying the install in safe mode shows it hangs while loading CLASSPNP.SYS which is the next line after DISK.SYS.

Suspecting a hardware problem I tried replacing the HD and DIMMs, neither of which make any difference. With the new HD the install process still hangs on CLASSPNP.SYS.

Oh and I ran memcheck86 and the hardware tests built-in to the bios (HDD and mem) none of which report any problems. I'm running the build in SMART HDD check now but considering I also tried a different drive that I know is good that is unlikely to turn up anything new.

Finally to make sure this isn't a problem with Windows 7, I tried installing XP SP3 from an old disk instead, but this also hangs while "Setup is starting windows" (I couldn't get into safe mode or find any way to enable logging to see exactly what causes the freeze.)

The ONLY thing I got to boot was an old Ubuntu 8.04 live CD. I can get the live CD to boot to desktop and all is well. I tried installing it to the harddisk but that also hangs. I can't see exactly why because the screen just goes blank and stops responding after I select "install" from the menu.

  • did your friend provide any info about what happened leading up to this issue? It may be a motherboard issue since you already tried different memory and a different hard drive. You could also try a different sata or ide port for the HDD. – Not Kyle stop stalking me Feb 10 '11 at 20:36
  • I tried swapping the ports. According to the friend it just happened one day to the next, but you know how reliable those reports are ;) I'm starting to think it must be the mainboard, it's the only thing I haven't replaced yet. – PeterD Feb 11 '11 at 9:33

after much hardship i found my answer. i have a hp 2000 note book pc and the problem was the legacy boot up option in bios being disabled. i enabled it and it booted up just fine and am installing windows 7 u right now. will update

  • during instal i encountered a problem. it was stuck at the expanding windows section of the screen. the fix is to unplug any device (ex mouse keyboard). it started loading right after that. – Joseph Pierce Jan 15 '13 at 3:53
  • that was my problem solved in its entirety thank you all so much for your help – Joseph Pierce Jan 15 '13 at 4:12

Well after much brain racking I finally figured it out. There's something wrong with the motherboard's onboard firewire. When I disabled it in the bios the system ran fine again. Thanks to everyone for the suggestions, but it seems it was a hardware problem in the end.


Follow the order given below.

  1. ) Use the Ubuntu boot CD to back up the important data to an external drive.

  2. ) Test the hard drive and memory, rule out hardware issues first. http://h30434.www3.hp.com/t5/Lockups-Freezes-Hangs/How-to-test-RAM-and-HDD-Hard-Drive/td-p/301638

  3. ) Run a chkdsk on the hard drive, then try to boot again. http://kb.wisc.edu/helpdesk/page.php?id=6565

  4. ) HP may have a Recovery Partition, you can attempt a Factory reset, this will reinstall W7 complete with drivers and HP software, so back up data first, see #1.



  • Thanks for the suggestions! We have everything backed up. Memtest86 didn't come up with any errors. I am running a full sector check of the HD now, although having replaced it with a known good HD and ending up with the same failure I doubt the drive is the issue. Will report back when the sector check is complete. – PeterD Feb 11 '11 at 21:54
  • Took a few hours but the sector check also came back clean. The recovery partition, although it's still present, doesn't appear to be working any more. Having tried with different install CDs, a different HDD, different memory modules, I think I've run out of options. Thanks again for all the suggestions, but unfortunately I think it's time to write this one off. I'll accept the answer because the suggestions are helpful still. – PeterD Feb 12 '11 at 17:40

I've seen such problem many times.
First thing you must do is unplugging all non-standard devices (USB mouse, webcam etc). Unplug as much devices as you can and reboot. It helps me in 90% of such cases. And after rebooting update your drivers.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.