On my Lenovo T400, Windows 7 can sleep but cannot hibernate.

When choosing hibernation, the screen turns black, but then there is one beep, and the screen turns back to what it was before choosing hibernation.

The problem seems changed and I didn't do anything.

When I choose sleep, the screen goes black, and all LEDs on the bottom of the lid do not change compared to before choosing sleep. i.e. the moon LED is never on and the wireless connection LED is never off. Does it mean the laptop cannot sleep?

When I choose hibernation, the screen turns black, and finally only two LEDs are on and they are battery and plug-in.

So now it looks like it can hibernate but not sleep?

Laptop specifications:

Operating System
    MS Windows 7 Home Premium 32-bit
    Intel Mobile Core 2 Duo P8800  @ 2.66GHz
    Penryn 45nm Technology
    1.9GB Single-Channel DDR3 @ 532MHz (7-7-7-20)
    LENOVO 2764CTO (None)
    ThinkPad Display 1440x900 @ 1440x900
    ATI Mobility Radeon HD 3400 Series (Lenovo)
Hard Drives
    244GB Western Digital WDC WD2500BEVS-08VAT2 (SATA)
Optical Drives
    AZCDW EFCPUZ452 SCSI CdRom Device
    AZCDW EFCPUZ452 SCSI CdRom Device
    Conexant 20561 SmartAudio HD

In Windows 7, "Hibernate" is not on by default. You have to enable this option with the command line powercfg tool.

Here is a tutorial:


I noticed Microsoft has "Fixit" scripts which might automate this as well:


  • Thanks! I had tried powercfg -h on before I posted the problem and it didn't help. Plus, it seems that my problem has changed. See my post. – Tim Feb 11 '11 at 4:51

I found out that one of the reasons why Windows 7 would not go hibernate was due to the hidden 100MB recovery volume has gone offline, for unknown reason.

In order to make hibernation work again, run DOS prompt as administrator then,

  1. Issue the command diskpart and press enter
  2. When the diskpart loads, issue the command select disk 0 and press enter, system should prompt Disk 0 is the selected disk.
  3. Next, issue the command detail disk
  4. System should now display a list of volumes on this disk. Look for the volume with 100MB size and note its number.
  5. Issue the commmand select volume n where 'n' is the volume number you have noted (usually it is 0)
  6. System should now prompt volume n is the selected volume.
  7. Now issue the command Online volume
  8. System should now prompt DiskPart successfully online the selected volume.
  9. Issue the command detail volume, verify that the volume is now Offline : No
  10. Finaly issue the command exit to leave diskpart, and issue command exit again to close the DOS prompt.

You should now be able to hibernate your system.

  • Finally! An answer that works. Thanks a lot Richard. – Alex Essilfie Dec 8 '13 at 12:43

You may have to check your BIOS settings to allow for all sleep modes. The BIOS doesn't allow all power states sometimes, even if your Windows setting do. That's what I would recommend checking, as if you're seeing the Hibernate option in the Start Menu, then Windows must think that it's enabled.

Also, make sure that you don't have any programs running that would not allow the computer to change to a low power state. This unlikely has anything to do with your problem, but it's worth a shot.

  • Thanks! How to check BIOS settings and to allow for all sleep modes? – Tim Feb 11 '11 at 3:46
  • 1
    While your computer is starting up, from a full off-state, you should be able to press a key, usually something like "Delete" or "F12", and that should allow you into the BIOS. In the BIOS, there should be a tab that you can navigate to with the arrow keys called "advanced", maybe one for "power." Anyhow, find something called "Sleep modes" or something like that, and change the value to S1 & S3. My guess is that it's probably on one of these two settings enabled right now. You need both enabled. – blackmastiff Feb 13 '11 at 19:35

I had the same problem and here is how I solved it:

  1. Right click the power icon in the bottom right corner and choose "Power options"
  2. click on the "Require password when wake up"
  3. select the option "Don't require the password" (since the password will wake your PC up about 3 secs after you hibernate)
  4. Now when you want to hibernate , you have to click on the Start button
  5. select "Switch User" first (don't select Hibernate because it will not working that time)
  6. After your PC went to the Switch screen, find the red icon (in the right corner) which has the options: Sleep/Hibernate/....
  7. click the Hibernate and wait for several secs to check if the LEDs go off. If it is , hibernation is successful.
  • Requiring a password has nothing to do with hibernating. – FKEinternet Jan 26 at 18:54

Basically it is due to Ubuntu. Just try the following steps as it resolved my problem:

  1. Open CMD and run as Admin
  2. Type powercfg.exe -h off (This remove the hiberfil.sys file)
  3. Type powercfg.exe -h on (This generates a new file)
  4. Type shutdown /h /f

You will see this message "The system cannot find the file specified." after Step 2. If so, then go to disk manager and mark the Reserved and Windows Partition as active.

By following all the step you will be able to Hibernate.

  • This has absolutely nothing to do with Ubutu - neither the answer nor the problem – FKEinternet Jan 26 at 19:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.