At some point in the past, I had installed posgresql and I can't get rid of it:

$ ps -A|egrep postg   232 ??        
287 ??         0:00.02 postgres: logger process                                                                                                                                                                                                                       
328 ??         0:00.09 postgres: writer process                                                                                                                                                                                                                       
335 ??         0:00.06 postgres: wal writer process                                                                                                                                                                                                                   
336 ??         0:00.03 postgres: autovacuum launcher process                                                                                                                                                                                                          
342 ??         0:00.01 postgres: stats collector process 

I'd like to stop it from starting up every time I boot, since fs_usage shows it keeps my disk occupied.

I've already tried adding POSTGRES=-NO- in /etc/hostconfig, but the processes keep spawing.

Also I've tried something I found on another post, with no luck:

$: locate postg|egrep plist

$: sudo launchctl unload /Library/LaunchDaemons/com.edb.launchd.postgresql-8.4.plist


But still postgresql processes show up :(

4 Answers 4


Note that with PostgreSQL 9.0 (and probably newer) on Mac OS 10.6.8 (and probably older), in order to prevent the PostgreSQL server from auto-starting, you have to:

  1. Go to /Library/LaunchDaemons/
  2. Open com.edb.launchd.postgresql-9.0.plist in an editor as root (replace 9.0 with your correct version number), e.g. sudo vim com.edb.launchd.postgresql-9.0.plist.
  3. Locate the line <key>RunAtLoad</key>
  4. Change the next line from <true/> to <false/>
  5. Save and exit.

That should do it. Also, if you want to stop the server immediately, without restarting, su to postgres and run /Library/PostgreSQL/9.0/bin/pg_ctl stop -D<your data dir>. You can find out which is your current data dir with ps aux|grep postgre.

Source: http://forums.enterprisedb.com/posts/list/2240.page#8321

  • com.edb.launchd.postgresql-9.0.plist wasn't found at this location for me.
    – AlecRust
    Jun 9, 2015 at 22:32
  • @AlecRust Did you locate it? Try ls -al /Library/LaunchDaemons/*postgre* to see if it's not a different version of PostgreSQL you're using.
    – Dimitar
    Jun 10, 2015 at 14:27
  • 4
    I've looked within /Library/LaunchDaemons, no mention of postgres (note: installed through Homebrew). Using PostgreSQL Mac Preferences in the end to manage this.
    – AlecRust
    Jun 10, 2015 at 21:02

This one worked for me

cd /Library/LaunchDaemons/
sudo rm com.edb.launchd.postgresql-9.0.plist

Found this:

In Mac OSX: (Assuming Default Locations)

Via uninstaller:

  1. In the installation directory, there will be a uninstall-postgresql.app file will be there, executing (double clicking) that will uninstall the postgresql installation.

Manual Uninstallation:

  1. Stop the server

sudo /sbin/SystemStarter stop postgresql-8.3

  1. Remove menu shortcuts:

sudo rm -rf /Applications/PostgreSQL 8.3

  1. Remove the ini file

sudo rm -rf /etc/postgres-reg.ini

  1. Removing Startup Items

sudo rm -rf /Library/StartupItems/postgresql-8.3

  1. Remove the data and installed files

sudo rm -rf /Library/PostgreSQL/8.3

  1. Delete the user postgres

sudo dscl . delete /users/postgres


Search for the below packaged file name


This will be found at cd /Library/LaunchDaemons/.Remove it if you don't need.From the Question perspective make changes to true to false at RunAtLoad

It works like a charm for me

  • Welcome to Super User! This duplicates another answer and adds no new content. Please don't post an answer unless you actually have something new to contribute.
    – DavidPostill
    Dec 10, 2016 at 14:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.