My Mac doesn't recognize my iPhone when I plug it.

Here is the configuration: (basically everything is updated)

  • 10.6.4 mac system (Snow Leopard)
  • XCode version 3.2.5
  • iTunes 10.1.2
  • iPhone 4 , 16 GB, iOS version 4.2.1

I tested for a few days with no problems but now it does not recognize it anymore. My provisioning profiles are brand new.

It's not detected in iTunes, nor in the XCode Organizer.

First it told me that there is no provisioned iOS Device connected. I deleted the iPhone from the Organizer and hoped it would get recognized again, but that didn't happen.

I tried restart everything (Mac/iTunes/XCode/iPhone), but nothing worked. Do you have any ideas?

I would be more interested in making it work with XCode right now. I don't really care about music and stuff.

  • 2
    does it recognize it in itunes? is your cord bad? – Jesse Naugher Feb 11 '11 at 18:13
  • Sounds like this should be moved to superuser. It isn't necessarily programming related since even iTunes won't recognize your device. I'd suggest getting that working first. – raidfive Feb 11 '11 at 18:13

Download the iPhone Configuration Utility from Apple. Quick and easy and now iTunes and xCode can see my iPhone again!

| improve this answer | |
  • It won't let me vote yet - the "iPhone Configuration Utility" was exactly right - install the unility (you don't even need to run it) and xcode behaved – user68755 Feb 23 '11 at 8:38
  • 1
    Thanks, this one worked for me. After Xcode 4 install both iPad and iPhone wouldn't show as connected. +1 – Robert Conn Feb 24 '11 at 20:36
  • I would have treated you if you were here! Thanks! – Raj Pawan Gumdal May 27 '11 at 18:06

Check if your device is recognized in System Profiler. (Apple -> About This Mac -> More Info -> Hardware -> USB)

If not, you can try putting the device into restore mode. First, make sure that your device is unplugged.

Then, press and hold both the home button and the sleep/wake button. When the Apple logo appears, release the sleep/wake button but not the home button. Keep pressing the home button until you see "Connect to iTunes".

Now, connect to iTunes and it should detect an iOS device in Restore Mode. This should help.

| improve this answer | |
  • Hello Moshe, I did this, but only got to that screen if I connected the phone before starting the process. Without connecting it , I got to other stuff like Voice Control...don't know it started. So , I'm connected, I get to the screen that tells me to connect to iTunes...what should I do then? Am I not already connected? P.S: The device wasn't in the System Profiler under USB. – George Feb 11 '11 at 19:53
  • I've edited my answer. (Try different USB ports and cables if possible.) – Moshe Feb 11 '11 at 19:53

Happens sometimes because the iTunesHelper process hangs. Do as follows:

  • quit iTunes
  • in Terminal go: sudo ps aux | grep iTunes
  • if iTunesHelper is in the list, kill -9 it
  • start iTunes

Should be good as new.

| improve this answer | |
  • This worked for me! – Joon Jul 27 '16 at 16:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy