I have a bunch of JPG-files which I want to stitch together with Photoshop's Photomerge function.

I choose FileAutomatePhotomerge... and browse for the files. Photoshop opens the files and starts analyzing. I see the process bar filling and different phases are mentioned on the process bar. Nothing weird there.

When the merging is done (and if I don't blink my eyes), I can see layers-palette is populated with the chosen files and, by quickly judging from the layer thumbnails, they're properly aligned. Sometimes the image window itself can be seen, but not always.

Problem is that the layers and the image disappear in a flash. There is no error message. Everything is like prior starting the photomerge. No file has been changed. I could continue to use Photoshop normally.

This is what I've tried so far:

  • Loaded folder which has 38 JPG images, 4272 x 2848 and ≈ 5 megabytes per file
  • Loaded the same files, but chose Use Files instead of Use Folder in the photomerge's window
  • Loaded 19 JPG images, 4272 x 2848 and ≈ 5 megabytes per file
  • Loaded 10 JPG images, ⇑ see above
  • Loaded 5 JPG images, see above
  • Loaded 3 JPG images, see above
  • Scaled the images to 2256 x 1504 and ≈< 1 megabytes per file
    • Loaded in a set of 38, 19, 10, 5, 3
      Following steps are tested with these smaller files and with a set of 5 images
  • Read Adobe's forums and reduced the amount of RAM Photoshop uses gradually from ≈ 80 % to 50 % (though I didn't understand the logic behind this)
  • Would've reduced cache tile size to 128K, but it was set so already
  • Disabled OpenGL
  • Scaled the images to 800 x 533 and ≈ 100 kilobytes per file, loaded a set of 5
  • Read more unanswered threads around the internet

In between each test I closed and reopened Photoshop. This is the first time I've even tried using photomerge.

Am I doing something wrong? How can I locate what is the problem? How do I fix this?

Photoshop is 64 bit Extended CS5 version. I'm on a mid-2010 quad-core (i5) iMac with up-to-date Mac OS X 10.6.6.

Edit: Weird. First loading the images into one file via FileScriptsLoad Files into Stack… and then using EditAuto-Align Layers…, which, effectively, is the same as photomerge (even the dialog looks kind of the same), works! Even with the original JPGs without any issues.

This doesn't fix photomerge, though.

  • 2
    To answer: "am i using photomerge wrong" - No, I've done this exact process at least 5+ times, and i get the the progress up to the layers aligned and masked, except then mine don't disappear, i.e. it works. Of course this doesn't help you solve the problem, but might help you not feel crazy
    – Hemi
    Feb 14, 2011 at 2:08
  • @Jaips It does help me to solve the problem, ie. I can narrow down the possible issues. Thanks! Feb 14, 2011 at 11:15

5 Answers 5


I have found that if your ruler units are set to "percent", it causes Photomerge to fail as described by the OP, and others in various threads.

I tested this by trying to merge 5 photos with various setttings of RAM use, cache levels, and ruler units, and found that regardless of my success with RAM and cache settings, it always failed when my rulers were set to "percent".

I'm not sure where to bring this to people's attention in the future when they ask about Photomerge problems, short of mentioning it in all the major Photomerge problem threads. Not even sure if that's what was causing most/any problems for people, but it's something to at least rule out when troubleshooting.

  • This, almost unbelievably, is correct and I've retracted my false answer and accepted yours. To give your answer more visibility there is an open bounty which will be awarded to you. Feb 25, 2012 at 8:57

Clear Photoshop's Settings File by pressing and holding Ctrl+Shift+Alt immediately after double-clicking on photoshop.exe.

Then you have to set everything back again, but hey... it works!

Remember to save your keyboard shortcuts if you have any custom ones, because they will reset also.


I tried the suggestions above (having same problem with disappearing), and the only way I can get around it was to go through

  1. load files into stack
  2. auto-align layers
  3. auto-blend layers and it achieved the basic same result.

However, I tried ctrl+shift+alt when I opened PS and that didn't solve the problem, nor did opening the files individually and trying photomerge. Other sites I checked suggested updating drivers, but it seemed it was only able to be done with windows/PC computers.

Photomerge is still not operating normally.


I tried the suggestions provided but I found that for all of them you had to work around Photoshop in an inconvenient matter.

If you are using the 64 bit version of CS5 try switching to 32 bit. Worked for me.


I had the same problem, but then I opened every picture as a separate file in PS, tried photomerge, clicked "Add Open Files" in the Source Files dialog, and for some reason that worked!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.