I have latest generation Macbook Pro 7.1 (Intel Core 2 Duo) running Mac OS X 10.6.6. I installed Virtuabox 4.0.2 and tried to boot Ubuntu 10.10 64-bit iso. The boot options screen from the live CD came up:

enter image description here

However when I continued to load the live session, or installer for that matter, I encountered the following error:

enter image description here

This kernel requires an x86-64 CPU, but only detected an i686 CPU. 
Unable to boot - please use a kernel appropriate for your CPU.

I am not sure if VT-x is enabled or is supported in the Core 2 Duo of my Macbook Pro. But at least, I have both I/O APIC and VT-x enabled for hardware virtualization as told in the Virtualbox manual.

enter image description here

enter image description here


You should go back to your virtualbox "new machine wizard" (it's the thing that opens when you hit "new") then when selecting your OS Type, select "Ubuntu" and switch the Version to "Ubuntu (64 bit)". This makes sure it enables the 64bit processor extensions for your machine.

  • 2
    Yep, that worked for me! It's a little odd that VirtualBox doesn't seem to make the CPU type selection a little more explicit/obvious. After all, someone might want to emulate running a 32-bit OS on a 64-bit machine. – Dan Moulding Jan 11 '14 at 5:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.