I just tried to set up a VM using VirtualBox and Ubuntu 10.10 desktop edition. Installation proceeded fine, but at ~60-80% I got a message that it failed and it's most likely a defect CD or a read error. So I checked the MD5 sum of the ISO (ubuntu-10.10-desktop-i386.iso) which gave me 5f4ab3c8e40f8dda084213caa842325c, but should be 59d15a16ce90c8ee97fa7c211b7673a8 according to various sources, including the official MD5 site.

I redownloaded and got the same wrong MD5 sum, after that I used the BitTorrent download - still the same wrong sum. All downloads were made from http://www.ubuntu.com/desktop/get-ubuntu/download , I'm trying a third download right now from german CHIP, perhaps this will give the correct MD5 sum (EDIT: No, this even gives another wrong one: 0eb8d63d6eba4710754a36e123b4c4c3).

I tried different MD5 sum checkers (no difference) and googled for the MD5 sum (0 hits). My PC is a netbook with Windows 7 Starter.

Any ideas?

UPDATE: Got the correct MD5 sum now by downloading via BitTorrent again. Memory and HD seem to be OK, thanks for all the help.


Trying to grab the torrent was a good move. Most BitTorrent clients will let you re-check downloads, which will quickly tell you if your download is corrupted.

Now for the bad news: the fact that you downloaded the ISO file from multiple sources and still ended up with corrupted files points to a possible hardware problem on your netbook (most likely a damaged hard drive controller). To see if this is the case, use another PC to download the same ISO file. Run a hash check on that PC to verify a clean download. Then, copy the ISO over to your netbook and run a hash check again.

Another way of looking for controller problems is to open uTorrent (or your BitTorrent client of choice) and force re-check everything you've downloaded in the last few weeks. If a bunch of your downloads change from 100% done to 99% done (or any similar number), your hard drive controller is at fault.

  • Accepting this answer, this would've been my next moves (additional, I'll do the memtest Nighthawk suggested). I'll update the question with further results in the next days. – schnaader Feb 13 '11 at 18:49

You might also want to run memtest86 to verify that your memory isn't bad. It's possible that you've got a few bad spots in RAM that are corrupting your downloads. If you can get a known good copy of an Ubuntu CD, you can boot the netbook off of it and start memtest86 from there. You can also get a standalone version here

  • Good idea. No CD drive on the netbook, I'll try with an USB stick. – schnaader Feb 13 '11 at 18:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.