Running Macbook Pro OS X 10.6.3 Accessing an HP OfficeJet 5610 plugged in the USB port of a US Robotics router.

I tried several combinations of:


  • Internet Printing Protocol (IPP)
  • Line Printer Daemon (LPD)
  • HP JetDirect (socket)



  • HP OfficeJet 5600 Series

Whenever I try to print, it fails while saying "connected to printer" or "Printer is busy...zill try again in X seconds"

Both Windows 7 and Windows XP computers on the network can successfully access this printer, identifying it as "HP5610 on"

I tried clearing all tasks and printers (ctrl-click in the menu), and resetting it to (socket,, HP5600 series) but to no success.

  1. Make sure your printer is on and connected to the USB port on the router.
  2. In OS X go to System Preferences.
  3. Click on Print & Fax.
  4. Click the lock (to unlock) to make changes. Enter your password if you need to.
  5. Click on the plus (+) sign at the left to add a printer.
  6. In Leopard/Snow Leopard click on the IP tab.
  7. In the Protocol drop down, select HP JetDirect - Socket.
  8. In the Address drop down, type the IP Address of your printer (
  9. Leave Queue blank.
  10. Give a descriptive name [Network Printer].
  11. Give a descriptive location.
  12. In the Print Using drop down either select your driver or choose the "select a driver to use" option.
  13. Choose the appropriate driver for your printer.
  14. Press OK and then click Add.

That should do it. Always add a new printer instead of modifying an existing configuration. Click the lock to apply and save your changes.

Source: http://aquatsr.com/static/ddwrt_wl520gu.pdf (Configuring a Printer in Mac OS X)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.