I've been trying to install VMware workstation 7.1.4 on my windows 7 computer. I know I've already posted something similar to this, but this totally different situation. Whenever I open the installer, this grey window labeled VMware workstation setup opens and nothing happens. Works on vista, but I don't use my Vista for this kinda stuff anymore. Help

enter image description here

  • Did you mean to include a screenshot or something?
    – Nick
    Feb 13, 2011 at 23:24
  • Cant help if you provided not enough information, screenshot at least, VMware workstation version, etc..?
    – Hieu
    Feb 14, 2011 at 2:03
  • @beth22- vmware workstation version- the latest one, and sorry, thats all the information i have. i tried to put a screenshot up, but it did not work, the site said something about me not being an old enough member (im new to superuser.
    – Shad
    Feb 16, 2011 at 0:32
  • @Nick- yes, i tried, but i wasnt alwed. superuser said i wasnt an old enough member.
    – Shad
    Feb 16, 2011 at 0:34
  • 1
    Were there any errors during vmware installation? Are there any errors in your windows event logs, particularly with a time stamp near your last attempted launch of vmware? Apr 30, 2011 at 13:49

8 Answers 8


This seems to be a quite common problem with many solutions.

From When installing VMware Workstation, the Setup window displays a blank screen.
To resolve this issue, you must replace certain files with the original version. To replace the files:

Open a command prompt and run these commands to re-register the necessary files :

32-bit version of Windows:

regsvr32 jscript.dll
regsvr32 vbscript.dll

64-bit version of Windows:

cd C:\windows\syswow64
regsvr32 C:\windows\system32\jscript.dll
regsvr32 C:\windows\system32\vbscript.dll

Restart Windows.

Other solutions may be to :

  • run the installation from an empty folder (only the installation package should be there)
  • make sure your AV does not block (better disable all antivirus and firewall)
  • make sure there are no processes running like webcam.exe or fixcamera.exe
  • run the installation package from the command line by adding /z action=install
  • run the installation using "Run as administrator"
  • go to registry key HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet Settings\Zones\ and delete a key L (make a backup first)

Or you can try this one:

  • To uninstall any old version, go to C:\Windows\Installer
  • Add the "Authors" column and sort by it
  • One of the .msi files with have a "VMware" author
  • Double-click it and follow through with the uninstall steps
  • To install the new version, run cmd.exe as administrator and do:

cd install-file-directory
install-file.exe /e tempfolder
cd tempfolder
run the .msi file (vmware workstation.msi)

  • last one helped. but before i uninstall the vmware and then did this instruction.
    – megas
    May 3, 2011 at 22:10
  • i was having this same problem but i was running it from another partition and moving it to the system drive fixed it Sep 14, 2011 at 20:56
  • I have done whatever has been written above and it has not worked. Please help
    – Sachin
    Dec 23, 2011 at 19:39

This helped me:

  1. Go to the following registry key:

    HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet Settings\Zones
  2. Remove the key which has a box as name "[]".

  • This alone fixed it for me.
    – Zitrax
    Mar 2, 2012 at 19:49

The MSI C:Windows\TEMP\vmware_1402472938\vmwareplayer_x86.msi failed: 'Could not write value to key \SYSTEM\currentControlSet\Services\Vmware\Performance'. Verify that you have sufficient access to that key

If you have this problem then this is not problem of VMware. Whenever you have MSI problem then its the problem of Windows Installer.

In these type of problem first go and check if the required folder is present in the Hkey_local. Eg(\SYSTEM\currentControlSet\Services\Vmware\Performance). IF not then create the required folder.
After long hours on computer I realized that the problem is so simple.

  • On command prompt Type regedit
  • The click HKEY_Local_Machine.
  • Then try to find all the folder , if the folder is missing create the required folder.

I had the same problem, but now I was able to install VMWare workstation 8 successfully on my Windows 7 32 bit laptop with the above said steps.

  1. I re-registered the necessary files rvgsvr files in command prompt.
  2. I deleted the registry entry L from HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet Settings\Zones\
  3. I copied the installation file to the system drive(C:).
  4. Then I was able to install the vmware.

The same installer is used and the same problem did occur with VMWare Workstation 9.

setup.exe reveals itself (right click:Properties>Details) to contain a boostrap.exe file which wraps around an msiexec file. The blank frame is actually an HTML site. Right click and "Show Source" to confirm. The underlying problem is a JavaScript error.

The problem is common on Windows systems which have removed the Internet Explorer.


Open a terminal and run setup.exe /e FolderpathToExtractTo

e.g. setup.exe /e c:\VMWareSetup

Go in the directory and run vmwareworkstation_x64.msi or vmwareworkstation_x86.msi and wait till it finishes. That's it. It definitely worked for VMWare Workstation 9.0

Be aware that an extraction with 7zip will fail.


I had the same error and solved it by renaming the file from setup.exe to buggy.exe.


In a file named, for example, uninstall.cmd:

echo off
MsiExec.exe /qn /X{0D94F75A-0EA6-4951-B3AF-B145FA9E05C6} /norestart
rd /s/q "C:\Program Files (x86)\VMware\VMware Workstation"
REG DELETE HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\{0D94F75A-0EA6-4951-B3AF-B145FA9E05C6} /f

Of course, adjust the MSI-Code (0D94F75A-0EA6-4951-B3AF-B145FA9E05C6) -> Workstation 9.0.2


If you have avast installed

To solve this problem just uncheck "hardware virtualization" checkbox on AvastUI troubleshooting page. (reboot is required to propagate this setting change)

more info here

  • 1
    Please post the relevant information from the link in your answer to avoid link rot, for more information please see How to Answer
    – 50-3
    Sep 8, 2013 at 22:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.