19

I'm using Windows 7 RC and for some reason, the date won't show at all on my system tray. It used to for a while, but one day it just stopped (I didn't even notice it until someone pointed it out).

So I've been trying to fix it, by customizing the format of the date, resetting to defaults, etc... But nothing works, it still doesn't show.

The time appears fine.

12 Answers 12

18

Make sure you have not changed your taskbar to use small icons only. This removes the date from the taskbar and only shows the time.

  • Right Click Taskbar
  • Properties
  • Use small icons
2
  • 1
    What did the trick, was actually resetting everything back to defaults, then setting it to small icons, then back to big icons. Weird, but thanks for the idea!
    – Anton
    Aug 19, 2009 at 0:35
  • 2
    But I want small icons and the date to be displayed. :(
    – bpcookson
    Jan 15, 2016 at 12:05
6

Win7 Pro used to show the month, then it disappeared. I now suspect that must have been back in July (short name). Now, it's November and with the taskbar too narrow (if vertical and left-aligned) may still show the time but, no day or date. All other suggestions I could find didn't mention this. I finally figured it out. Only took me FORTY-FIVE MINUTES!!! So, I'm passing it on to save some time for all you - okay, the other - vertical and left-aligned taskbar freak out there (if there is another one).

5

Wow, I figured it out...

So, by default in Windows 7 US editions, short dates in the taskbar are displayed as MM/DD/YYYY. This works OK until 10/1/2013, when the taskbar does not have enough room anymore (the month was only one digit before with 9) at which point the date disappears!

To fix this, you can set the short date to a format like MM/DD/YY with these instructions: http://www.tech-recipes.com/rx/4194/windows-7-customize-how-the-date-is-displayed-in-the-system-tray/

0
3

Alternate for anyone else looking as this sometimes occurs on fresh Windows 7 builds (RC and Retail)

Right-click taskbar Go to Properties Go to Customize (under Notification Area) Click on "Turn system icons on or off" Set "Behaviors" to ON for Clock

2

Check out this article Windows 7: Customize How the Date is Displayed in the System Tray. Make sure you have the date in the proper format.

2

It's a fault with Windows, you need to adjust your date format.

For example ddd d/M/yy will not work on my PC for Wed 12/10/11 which is today when I went looking for a solution.

I just now changed my date format to ddd d/MM/yyyy so it now displays as Wed 12-Oct-2011 and that solved the problem.

2

No. The issue is most likely that you turned on use small icons in your taskbar properties.

Right click on blank area in your taskbar and select properties from the taskbar. The Taskbar tab will display as default. Ensure the Use small icons checkbox is unchecked.

1

You can use small icons, you just have to make sure that the taskbar is wide enough. If you are using large icons it still might not show up if you have a wide date (like 12/12/2012).

Make sure the taskbar is not locked. Put your cursor on the edge until the arrows show up. Drag the taskbar and make it wider.

1

I was facing the same problem but I am now able to resolve the issue. Follow the steps below,

  1. Navigate to, Control Panel -> Clock, Language and Region -> Region and Language.
  2. Region and Language window will be opened. Click on "Additional Settings" button.
  3. Click on the "Date" Tab.
  4. And whatever are the defaults, replace the text in the "Short date" field in the "Date Formats" Section with "dd-mm-yyyy" and click on "Apply" button. And You Are Done... The date and time will appear again on the taskbar...
0
  • Search in the bottom right-hand corner next to EN
  • Click to show 'Show hidden icons' then hit 'customize'
  • On a new window [Control Panel/All Control Panel Items/ Notification Area Icons], you will see, on the bottom left-hand corner: Turn system icons on and off Click on it to see all system icons and choose the one you wish to turn on or to turn off.
1
  • This does not appear to solve the original problem.
    – DavidPostill
    Oct 6, 2014 at 15:15
0

In my case, the date disappeared from the notification area when the month of September started. Since that month has 9 alphabets the notification area could not show this length as my date format was like this "05, September 2017". I got it fixed by shortening the "short date" in the date and time customization i.e. from this "dd, MMMM yyyy" to "dd, MMM yyyy".

Hope this helps somebody with similar case.

0

For users who are putting the taskbar at the left or right, the date disappears when it turns october

Time

before the date should be formatted as 1/30/2014 or 9/10/2017. When the date turns october (10), the date cannot be displayed due to the increase in width 10/22/2017. But still, it would show when the date turns one digit down like 11/1/2018 or 10/3/2018.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.