Having kernel IO errors in the console, extremely slow boots, and reproducible freezes.

Tech Specs:

  • Macbook Pro Early 2008
    • 4 GB ram
    • 500 GB Seagate Momentus XT HDD/SSD hybrid drive (installed late 2010)
      • Up to date firmware (SD24) a couple weeks after installation (no problems since, until now)
    • OS X 10.6.6
    • BootCamp Windows 7 Ultimate 64bit

I have a small portion of the console output here (drop box link to .rtf)

Windows 7 Partition works fine. Boots normal, operates normal.

I get the line kernel disk0s2: I/O error a lot. It is reproducible on:

  • Right click on anything on the dock (~5-10s hang, no beachball)
  • Wrench icon in Chrome (latest version) (~45-60s hang, no menu, beachball, then ~20-40s hang, menu open, no beachball)
  • Resolution change or external monitor connected (dvi-vga, been using it for > a year) (~20-30s hang on blue screen, then ~10-40s hang on desktop, readjusting sizes)
  • Choosing a space from Spaces (~1-6s hang)

It also happens other times, that I'm sure have a pattern, I just haven't seen yet, but I don't think it is random.

What I have tried:

  • Using Disk Utility from within OS X to verify the partition, check/repair permissions
    • no major problems found
  • Using Disk utility from the snow leopard disk to repair the partition
    • no problems found
  • do a disk check from within windows 7
  • Using OnyX to clear system/user cache
    • No effect
  • Using OnyX to check S.M.A.R.T status
    • Verified
  • Using OnyX to verify disk
    • No problems found
  • Using original system disks to perform "Apple Hardware Diagnostics" (quick and extended)
    • No problems found

Any ideas? I haven't yet tried reinstalling OSX. I have fairly up to date backups (time machine in OS X and manual in Windows 7) - but I'd prefer to not have to format the hard drive.

Edit: Boot time is ~4-10 minutes for OS X. Still ~1 minute for Windows

Edit 2: Forgot to mention - spotlight is slow, or non functioning. This may be due to the disk scans and such. OnyX has an option to re index that I haven't had a chance to try yet.

Update did a restore from a time machine backup from before the issues, now it won't boot at all. Hangs at apple loading logo for 30+ minutes.

Update 2: Did a "fresh install" of system files over my existing partition. I assumed this would erase everything. Fortunately (though I don't know how) when it booted (in < 1m) after the install, my files were there from the restore point I tried in update 1. No more errors, and it's running fine. I think it had to be some system file(s) corrupted, causing it.

  • Although you ran quite a few diagnoses, have you tried another disk, e.g. if you still have the previous HDD? Restore OS X from Time Machine on it and see if the problem persists. – Daniel Beck Feb 15 '11 at 13:55
  • @Daniel Beck For restoring from Time Machine, do you mean format the partition, reinstall and restore? Would that require cloning/restoring the windows partition as well? – xdumaine Feb 15 '11 at 14:00
  • I mean restore from Time Machine during OS X setup. IIRC you can restore the whole system, without installing it first. But I wouldn't count on old data to still exist afterwards. You can restore without your Windows partition. – Daniel Beck Feb 15 '11 at 14:02
  • I'll give that a try later. I'm at work, now. – xdumaine Feb 15 '11 at 14:14
  • I believe this belongs to apple.stackexchange.com – Brave Newbie Feb 15 '11 at 14:32

Those disk I/O errors usually mean you have a bad block that the drive has not had a chance to lock out yet. Modern drives automatically lock out bad blocks, but usually only when that block is written.

If you already have a good backup of your data from that partition, then boot from another Mac OS X disk (such as your Mac OS X Install DVD) and use Disk Utility to do an erase WITH "Zero Out Data" of that partition, and then restore from your backup. Note that you have to do the "Zero Out Data" to guarantee that every sector on that partition gets written to.

If I were you, I wouldn't trust that my Mac OS X partition was the only place on the disk to have a back block. I'd want to do an Zero Out Data erase of my entire drive. But of course you'd need to make sure you have good backups of your other partitions as well.

up vote 0 down vote accepted

Doing a restore from an old time machine backup resulted in the OS not booting at all. I did an install of OS X 10.6 over the existing partition with the snow leopard disk. It must have preserved user files/settings, while overwriting the system files. This solved the issue.

Even though there were signs that there was a bad block on the disk, multiple tools from Apple and multiple third party tools all indicate the disk and memory were ok, and there are other possible causes to this problem.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.