41

I have been experimenting with VMware workstation. When I autohide the toolbar at the top, it leaves a 1 pixel sliver. While this is functional, my OCD is bugging me. Is there a way to totally hide the toolbar?

  • 2
    You really should consider changing the accepted answer..... – Android Dev Aug 1 '17 at 11:34
-3

If this is a desktop machine, you can try adjusting the positioning of your LCD monitor to shift one pixel up.

The only other way I know of is to go to "Quick Switch" mode, then go to the menu bar and select View and deselect tabs.

This will give you a screen with no borders at all, but you can still get to a menu at the top of the screen. However, you lose the quick switch ability - but it should do what you want!

  • 1
    Perfect!! , this works very well :D – SkinnyGeek1010 Feb 17 '11 at 0:19
  • 1
    This answer applies only to very old versions of VMware Workstation. "Quick Switch mode" hasn't existed in a long time. – jamesdlin Oct 18 '17 at 19:26
73

Took me a little searching to find the answer to this because I didn't want to change the position of my screens. If you go to Edit > Preferences > Display > Uncheck "Show toolbar edge when unpinned in full screen" you'll be all set!

  • 28
    This should be accepted as the real solution. "Shifting your LCD monitor one pixel up" is just hideous. – Ray Mar 22 '14 at 19:48
  • yes this should be accepted – Xin Meng Nov 10 '17 at 16:22
  • It's only a half solution: when you let the mouse for a long time on top of the screen (that's often needed to make a menu appear in the guest OS), the VMware top bar appears again (even with "Show toolbar edge when unpinned in full screen" unchecked), that is annoyting when in fact you want to make the guest OS menu appear. Real solution: View > Exclusive mode, then the top bar won't appear again, until you press CTRL + ALT. I don't know if it's possible to have Exclusive mode by default for a VM. – Basj Apr 24 '18 at 14:00
  • @Basj You could run VMs though vmware-kvm if you want to run them in be in fullscreen all the time with no UI. – jamesdlin Jun 14 '18 at 5:15
30

For VMWare Player users, you can edit the preferences file at

%APPDATA%\VMware\preferences.ini

and add:

pref.vmplayer.fullscreen.nobar = "TRUE"
  • 6
    This worked for me. Of note: The specified path includes some hidden elements, so you cant simply browse to it (although search for VMware worked). Also of note: To get out of full screen, you need to Ctrl+Alt followed by Ctrl+Alt+Enter. – nobar Jun 27 '15 at 5:29
  • 2
    This worked great, note do the change while VMWare Player is not running. – Dean Meehan Nov 10 '15 at 11:19
  • 1
    This should be the accepted answer. FYI, it works with the latest VMware Workstation Player (v12). – dr01 Jun 9 '17 at 18:44
  • "TRUE" vs. "1" shouldn't make any difference. – jamesdlin Oct 16 '17 at 21:55
  • 1
    This solution works for me with Player 14 version 14.1.2 build-8497320 The only problem is to leave a full screen mode without a top bar. Simple ctrl+alt+enter does not work. It is needed to hit ctrl+alt first and then ctrl+alt+enter. – Alex Jul 2 '18 at 20:29
18

Go fullscreen, then select View -> Exclusive Mode from the menu.

You can press the host key (default Ctrl+Alt) to get out of it.

  • Sweet! This is exactly what I needed for Xubuntu which has it's task bar on top. Thank you! – Alexander Rechsteiner Dec 25 '13 at 15:06
  • 1
    this should be the accepted answer; vmware workworkstation 10 does not have the other options – nimsson Sep 8 '14 at 13:03
  • 2
    Any way to make this setting permanent?. – Jaime Hablutzel Nov 11 '16 at 15:36
2

I am going to try to give a definitive (and somewhat authoritative) answer for Windows hosts.

VMware Workstation (Pro) for Windows hosts

The full screen toolbar can be completely hidden directly via the UI. On Windows, go to Edit > Preferences > Display and uncheck "Show toolbar edge when unpinned in full screen". (Doing so will write pref.fullscreen.toolbarPixels = "0" to your %APPDATA%\VMware\preferences.ini file.)

Entering "Exclusive Mode" also will completely hide the full screen toolbar. (Exclusive Mode additionally will force most keyboard shortcuts to go to the guest instead of allowing them to be intercepted by the host.)

VMware (Workstation) Player (and VMware Remote Console) for Windows hosts

Unfortunately, there is no UI to directly hide the full screen toolbar completely. You will need to:

  1. Quit all running instances of Player.
  2. Modify your preferences file directly and add the line:

    pref.vmplayer.fullscreen.nobar = "TRUE"
    

    The preferences file is located at %APPDATA%\VMware\preferences.ini. (%APPDATA% is an environment variable that typically expands to something like C:\Users\YOUR_USERNAME\AppData\Roaming.)

  3. Restart Player.

Some other answers have suggested that using "1" is necessary instead of "TRUE", but they are completely equivalent. Any claims otherwise are likely from experimental error.

Alternatively...

For people who want to run VMs in full screen mode all the time with no UI at all, I would recommend running them in vmware-kvm.exe, which allows switching among running VMs and the host via a configurable hotkey. See the product documentation for usage instructions. vmware-kvm.exe is included with VMware Workstation (Pro), VMware (Workstation) Player, and VMware Remote Console.

(Disclosure: I worked on the VMware Workstation, Player, and VMware Remote Console code for many years and wrote vmware-kvm.exe.)

0

Press Ctrl+P, select Display, in Menu & toolbar uncheck Show toolbar edge when unpinned in full screen. Now go to full screen by pressing Alt+Ctrl+Enter. Bar is removed.

0

The answer eddiegrove gave was almost correct; however, there needs to be double quotations around the number 1

So just write:

pref.vmplayer.fullscreen.nobar = "1"

Then it should work.

  • Your answer is actually wrong because your straight double quotes got converted to smart quotes, so anyone who copies and pastes from your answer will have a bad time. Also, "1" vs. "TRUE" shouldn't make any difference. – jamesdlin Jun 14 '18 at 5:21
-1

Finally found out the answer Go fullscreen the go to view ad select exclusive mode note: "ctrl+alt+enter" to exit fullscreen mode hope this helps :)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.