I'm experiencing a problem with my Fedora 14 XFCE spin, which doesn't seem to let me pass the login screen: I enter my password for my user record, authentication passes (no 'Authentication Failure' message, which was when I tried to login as 'root' without root login enabled), and the screen becomes black (command line) for a couple of seconds and (voila!) my login screen emerges again.

I did nothing to cause that, it just suddenly logged me out when I was editing window manager settings via XFCE's built-in GUI utility (choosing window decorations style, from the listbox on the left)

For the first time, I had to boot from live CD and do a fresh install, but I don't really want to do that again.

Is there some way to repair this (maybe login via command line and reset window manager settings, I don't know really)?

  • The same thing just now after 2-3 reboots :(
    – Bubba88
    Feb 17, 2011 at 6:48

3 Answers 3


Try resetting your XFCE configuration:

mv ~/.config/xfce4 ~/xfce-config-backup
rm -r ~/.cache

If that doesn't work, try starting XFCE from the command line and see if it displays any errors:

  • Thx, I'll try it today, when I'm at home :) I Hope I didn't forget the correct keystroke for logging into the command line - Ctrl+Alt+F1?
    – Bubba88
    Feb 17, 2011 at 11:16
  • Ctrl+Alt+F6 actually
    – Bubba88
    Feb 17, 2011 at 12:43
  • I've repaired xfwm with the help of you advice. It was that 'Wildbush' xfwm4 theme that caused the crash. All I needed is to login via command line, then navigate to ~/.config/xfce4/xfconf/xfce-perchannel-xml/xfwm4.xml and set the theme property to something else. Thanks again :)
    – Bubba88
    Feb 17, 2011 at 15:52

Have you tried resetting your user's password?

Login as root and use one of the nice gui tools if available in xfce or type the following into a terminal:

passwd username

Try the following as root. Your /tmp directory may have the wrong permissions:

chmod a+rwx /tmp
  • Can you please explain what you did to make my command look better? I'm not sure what the tags are here.
    – cokedude
    Oct 8, 2011 at 23:12

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .