6

Specifically, I'm trying to install NERDtree. I downloaded the 4.10 package from github, unzipped it into ~/.vim/, and restarted MacVim (version 7.3).

Typing :nerdtree results in the following error:

E492: Not an editor command: nerdtree

In terminal, typing:

cd ~/.vim
ls -R

Results in:

Rakefile    doc     nerdtree_plugin plugin

./doc:
NERD_tree.txt

./nerdtree_plugin:
exec_menuitem.vim   fs_menu.vim

./plugin:
NERD_tree.vim

What am I missing?

5

The command is :NERDTree—case does matter, especially since only internal Vim commands can start with a lowercase letter.

If you followed the installation instructions you should be able to do ":help NERD_Tree.txt". If not, do ":helptags ~/.vim/doc".

| improve this answer | |
  • This was it. Thank you! I had also tried NERDtree, but I never tried it with a capital T. :\ – Closure Cowboy Feb 22 '11 at 1:02
  • 2
    @Closure Cowboy: that's still a lot to type. Typing ":NE" then hitting tab does the job for me, because vim has auto-completion in the command line. – vtest Feb 24 '11 at 16:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.