So I got home today to find that my KDE login screen would not let me log in. It said the authentication process failed or something and I needed to terminate the screen lock process manually. So I go over to another virtual terminal and try to log in. As soon as I enter my user name, a bunch of errors come up and I am unable to log in. "This can't be good" I think to myself, and reboot.

I am greeted by this error upon booting:

enter image description here

The error says that it says it cannot find /sbin/init. I loaded up a Ubuntu live CD and verified that /sbin/init is indeed present and all my other files still seem to be there. I tried booting into arch fallback on grub but that didn't work either.

Midway through the day I SSHed my desktop from my phone and started it doing an upgrade. I was able to log in then so I assume this problem had not occured yet, and it may be the cause of the problem. I have no idea how to fix it, urgent help would be appreciated.

  • I re-installed my OS to circumvent this problem, but I'll leave the question open just in case somebody does come up with a solution it will be visible to all. – DWilliams Feb 24 '11 at 14:10

What I usually do early on in situations like this is boot from a rescue or live cd so that you can mount the root filesystem independently. I'm not sure about ArchLinux, but often times the install CD/DVD that you used will have a rescue mode or live mode that uses the CD media and you can mount the root on your hard drive from that. Usually you do something like this:

sudo mkdir /mnt/myroot
sudo mount /dev/sda1 /mnt/myroot

If the filesystem mounts ok, then just take a quick look at the base directory and also sbin, bin and lib to make sure the files are there. You can probably do a general comparison with the Live CD's own /bin, /sbin and /lib.

If the filesystem doesn't mount ok then it probably needs to have fsck run on it, which you should probably do anyways.

  • The filesystem does indeed mount ok in a live CD and the files in question are indeed present. – DWilliams Feb 22 '11 at 2:41

I had a serious problem with ArchLinux and its IP problems. (i do not still know why they dont care this which is the key). To fix if you crash the system do as following:

  1. make a liveCD better if not make the one liveUSB as following:

    $ cd /tmp; wget http://releng.archlinux.org/isos/2011.08.19/archlinux-2011.08.19-core-x86_64.iso $ ll /dev/sdb $ fdisk /dev/sdb press p to view, press d to delete, press w to write $ dd if=/tmp/archlinux-2011.08.19-core-x86_64.iso of=/dev/sdb .........wait........... ..........make sure you have bootable liveCD now or liveUSB?.......

  2. Put that liveCD or liveUSB to your crashed system, normally you do it with BIOS

  3. mount your drive as mentioned by deltraray as following:

    $ mkdir /mnt/myroot $ mount /dev/sda1 /mnt/myroot |__| | this can be 1 or 2 or 3 etc.. try one after another if you are not sure in my case i tried sda1 failed, sda2 failed sda3 worked

  4. Now modify the file that is auto getting started such as applications

reboot and hope this helped.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.