I wired the Cat5 in my house seven years ago. The wired ports have worked fine with both my Windows XP laptop and MacBook. My wireless network also works fine, but I like to use wired occasionally.

One of the Cat5 runs wasn't terminated with a jack, so I recently terminated this wire with a port/jack on the wall end and a standard Cat5 plug on the end that plugs into my router. This is the same setup as my other runs.

Unfortunately, the MacBook isn't working well with the new wired port. The OS X Network System Preferences show the IP, Subnet, Router, etc., and everything looks fine. A "netstat -ibd" shows no errors or dropped packets. However, when I open a page in Safari, the status says "Contacting 'www.google.com'" and appears to hang. If I wait for a couple minutes, part of the Google page starts to display, but it is still not the full page load.

When I use a Windows XP laptop on the same wired port, everything works fine. An internet speed test shows good results and all web pages load fine. A "netstat -e" under Windows shows no errors.

I've used a Cat5 tester, and the cable tests fine (wires 1-8 light up in sequence). I've replaced both the port/jack and the connector twice to make sure I wired things correctly.

I'd really like this Cat5 to work with the MacBook (and I'm trying to avoid running a new length of cable). Any ideas what the problem could be?

  • I have no idea, but pretty obviously this HAS to be a software problem since it works under Windows. Hopefully some Mac guy will have insight. +1 for a great question though. – Shinrai Feb 22 '11 at 22:38

Just because the pins light up the cable tester in the right order doesn't mean you wired up your cable correctly.

The twisted pairs matter.

Please see my answer here for more information:

What's wrong with my custom LAN cable?

Short of studying up on the EIA/TIA-568-B wiring standard and making sure both ends of the cable meet the spec, one thing you could try is forcing your Mac to 10 or 100 mbit Ethernet instead of gigabit, and see if that makes it work fine. Also see what your XP laptop is negotiating. It's possible your XP laptop is only trying 100 mbit, but your Mac is trying gigabit, and that made the difference between working and not working on a sketchy cable.

Also note that there are different kinds of RJ-45's for different kinds of cable. The teeth that pierce into the individual conductors are designed differently for solid vs. stranded cable. See which kind of cable you've got in your walls, and then make sure you have RJ-45 connectors designed for that kind of cable. I avoid the hybrid RJ-45's that are supposed to have teeth that work with either kind of cable -- I'd rather have the kind that's specific to the cable type.

  • The feedback above and the other question you linked to were very helpful. I double checked the wiring on both ends of my cable, and the terminated end wasn't right. I cut it off and put on a new end. The cable immediately worked with the MacBook and Windows laptop. I feel stupid for missing a simple wiring problem, but I've learned some things about wiring. :-D – Dean Hill Feb 25 '11 at 17:59

check your networking settings for your Mac - it should as Shinrai mention, be a problem on the Mac side (not necessarily software too, the Mac's ethernet port may be busted).

Most common culprit usually is that you might have an incorrect proxy server set for the Mac. Try removing proxy server. Also, disable all other networking interfaces that is on except for the ethernet interface.

troubleshoot - you'll narrow it down sooner or later. Do a ping to see if the ping can get through to google for example.

  • +1 For disabling other network interfaces, especially if you run wifi in the house. This can cause all kinds of headache. – Iszi Feb 23 '11 at 4:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.