Today, I removed some old software from dad's vista, and installed SP1.

After which the computer restarted and it went into a "black" screen. I left it running for a few hours, and the laptop was really hot.

I tried to get into safemode, start from last known good start up, but nothing seemed to work.

i know it stops after loading \windows\system32\drivers\cplir.sys

what's going on and how can I fix his computer?


I'm still unable to fix my install. Repair and restoring the OS fail. The laptop has the vista partition built into it. I can't boot through a USB, and my other computer doesn't have a cd/dvd writer

Update 2

I tried chkdisk /f and although it fixed some errors, I still get the black screen of death.

  • Did you install SP1 using Windows updates? or some other source? – Moab Feb 23 '11 at 1:31
  • windows updates and the windows repair utility says that it could be culpit – dassouki Feb 23 '11 at 1:40
  • At this point, I would probably do a fresh install. If you haven't already, boot a livecd to recover/backup his documents and other data. You could then use a slipstreamed installation disc, so the service pack is installed from the very start. In any case, rule #1: Always make backups. – isuldor Feb 25 '11 at 9:55
  • @Brian - It's my dad's computer, although he still has his vista license (came with the computer) he misplaced the CD. Second, the other computer we have doesn't have a CD/DVD drive in it. – dassouki Feb 25 '11 at 9:57
  • When the screen goes black does the hard drive continue to grind? You said that the laptop was hot after a few hours, but I'd like to determine if this is related to the HDD or some other component. – ggutenberg Feb 28 '11 at 0:15

Quickest and easiest solution is to back up your files and re-install windows.

Repairing partition and boot info can be a painful task and 80% of the time recovering files and re-installing the OS is quicker.

Additionally, you gain the benefit of a new engine which is clean of nasties for your laptop with the re-install of the OS.


If the computer is not new, sometimes the strain of doing a heavy update job is too much for some weak and almost-failed part. As you say that you have restored the computer to its pre-SP1 state, but that the problem is still there, this might seem to point the finger to a hardware problem, better treated by a repair-shop.

There is also the rather faint possibility that when removing the non-specified "old software", you have also removed an essential part of Windows. Or, if the computer was infected, you may have only partially removed the virus and so rendered the computer unusable.

The best bet is to reformat the hard disk (the slow way, to "repair" bad sectors) and reinstall Vista, then apply SP2. As you seem to lack the means and the required boot CD, getting help from a qualified repairman (or a friend) may be the best bet. Also, if your Dad is lacking backups, you may need the help of a professional to save his data.

If the computer is rather old and you have the means to buy a new one, maybe it is time for an early Father's Day gift.


You can try to use System Restore to roll it back to pre SP1 status, read carefully...


If it boots after the restore, I would uninstall any AV or security software you have installed, and any software that has installed a Windows Service, then try SP1 again.

  • I tried restoring it as you said, but I still have the same problem – dassouki Feb 23 '11 at 7:47

I think the answer is that it's darn hard to figure out the cause.

By any chance, do you think this is a graphics driver problem? I've had this problem on Ubuntu before, where my NVIDIA graphics card used SoftEDID and wasn't recognized correctly. Have you tried switching between monitors (by pressing the LCD/Monitor key on your keyboard, if it's there), and seeing if that works? It's worth a shot.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.