Faced a strange situation at work today. We have people sitting at a table on opposite sides, with power cables underneath the table. This morning when the person sitting opposite to me banged his feet on ground, it disturbed the power cable to my PC and it turned-off. So when I turned it on, it says, "No boot device found" Press F1 to setup or F5 to perform test...

There was no physical impact/crash/fall of the desktop cabinet, which could have crashed/damaged the hard disk physically.

EDIT: The OS is Windows 7

So I tried to recognize it in the Bios setup, but even there it could not find the SATA disk that is connected to this machine.

So then I opened the cabinet, removed the power supply and plugged it back again. Tried to reboot, same error, "Boot device not found" It is not recognizing the hard disk.

Any ideas about what might be wrong? Hard-disk crash, OS Crash(But it doesn't even go to the point of loading the disk after the initial Bios execution, so doubt this...)

Any pointers about how I should proceed to troubleshoot/solve this error are welcome.


7 Answers 7


What i would do is this:

  • Listen if the HD starts to spin.
  • Check if every cable is connected (If it starts to spin the power supply is working).
  • If both is true try another cable and/or SATA/IDE Port
  • Put the drive into another machine if it still does not boot it will probably have some damage (Try to rescue it with fixboot, fixmbr and/or fdisk /mbr).
  • Try to rescue data with the other machine, if the drive gets recognized and spins (I would do this in any case. If the drive gets recognized save your data. It may be possible that this is the last time the drive comes to life.).

An i would fix the way of the cable layout below the table in a way this can not happen again in the future.

  • @Darokhtar: I would be trying this HDD in other working PC's. Just a query - Could a power supply spike due to abrupt turn-off-on cause any HDD damage, or the HDD controller damage like when a Cabinet falls and bangs on ground while on and thus crashes the HDD(I have seen this error recently with someone in office).
    – goldenmean
    Commented Feb 23, 2011 at 13:51
  • @goldenmean if the power cable is unplugged i think an spike in the power supply is unlikely, as the power is turned of rapidly, it is more like pressing the reset button. More likely is that the mechanic of the HDD gets damaged, or the cables loosen due to the mechanic force. The strange thing in your case is, that your BIOS does not recognizes the drive anymore. I've seen a broken motherboard, a failed HDD a failed power supply and broken RAM and Processor due to coffee in a keyboard. If hardware gets abused anything could happen. I can't explain that dramatic failure...
    – Darokthar
    Commented Feb 23, 2011 at 14:00
  • 1
    Replace the sata data cable, I have had several go bad for no good reason in Dell desktops.
    – Moab
    Commented Feb 23, 2011 at 14:24

While it's highly unusual for a power outage to damage a drive, there are several maintenance operations drives do and error checking routines Windows 7 performs. If a drive powered off during one of these operations it's possible the firmware on the drive could have been damaged.

The more likely option is that the computers BIOS settings have been lost and it's simply forgot the drive. To test this theory use F1 to get into setup and look for options relating to Quick/Quiet boot, disable them and reboot allowing the computer to run through a complete post. If it detects the drive normal operation should resume.

If this fails swap drive with your work partner and see if the problem follows the drive or the motherboard this will identify which is the issue. If the motherboard has taken damage time for a new board. If the problem seems to be the motherboard try opening and closing your dvd drive. If it works, proceed to replace the motherboard, if not it's actually your power supply not providing 12V, replace the power supply.

If it looks to be the drive it may be an issue with the drives firmware. If the drive is a Seagate 7200.11 it may be "bricked" if it's another drive this would be a similar issue. Both can be resolved in a data recovery lab if you have crucial data on the drive, If your data is backed up and this is the case it would be cheaper just to try a new drive.


If its not under warranty....Pull the HD out and slave it on another machine. If it recognizes and the partitions load there is hope. If.BIOS recognizes and there are no partitions try a high level data recovery tool like GetBackNTFS or RStudio. Good lucki


I've had three Vostro 220S machines go down in the last little bit - all out of warranty, so 2-3 year old and a bit more. All looked like HDD failures however, I thought I'd post here because I've been able to recover all three with new PSU's

Although the machines all power up, and can see the HDD's in the BIOS during Win7 install, they don't write or boot correctly. On one machine the telltale sign was wavy lines coming through the VGA to the monitor, very odd problem not often seen on LCD monitors.

My guess is that the PSU's are only just delivering enough power to the system when new ... over time their output is drooping a bit and its enough to cause the motherboard to look like its failing during periods of higher demand, like installation when the board, HDD and CDROM are all running.


First, try disconnecting and reconnecting SATA cables to disk and to motherboard. Reboot.

Second, try removing disk and plugging it to another computer. If disk works, then problem is either with your BIOS, cables or motherboard.

You can also try to connect another harddisk in place of your current (non-working) one, to see whether BIOS detects it correctly.


The HDD could be damage, or even motherboard... you should try insert other disk to your desktop and then check bios if there could not find any sata then its motherboard problem... and you can check if your disk work on another PC...

EDIT: but I think its probably HDD problem

In any case you will need contact dell service I think.


For this issue: try to use another SATA port.

Dell: the following series: XPS 8300, Vostro 460, Alienware M17x R.3, Alienware Aurora R.3, and XPS 17 (3D version), may have defective SATA ports that degrade with time.

On Dell Vostro 460, the blue and white (6GB SATA) should work, while two black (3GB SATA) may fail.




You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .