I tried to install the Windows 7 Service Pack 1 using Windows Update, and I got an error (code 80073701 - unknown error). I tried it again, same thing. Rebooted and tried again, same error.

Before I tried to install the SP1 I had installed all the previous updates.

I have Windows 7 Ultimate 32-bits.

What might be happening?


I installed the System Update Readiness Tool. Then, I tried to install the SP1 again, but the installation failed again with the same error. As I thought I was running out of options, I downloaded the SP1 package (500+ MB) and tried to install manually. Before that, I reinstalled the SUR Update. Well, the manual installation of the SP1 failed again. Then I learned about the c:\Windows\Logs\CBS\CheckSUR.log file (thanks Patches!). I checked it out. As I installed the SUR Update multiple times, the older logs are kept in the c:\Windows\Logs\CBS\CheckSUR.persist.log file. The first time the SUR update was installed there was an error, which is said to have been fixed. In the subsequent logs, no errors were detected. The log with the error:

Checking System Update Readiness.
Binary Version 6.1.7600.20593
Package Version 7.0
2010-03-19 09:57

Checking Windows Servicing Packages

Checking Package Manifests and Catalogs
(f) CBS MUM Corrupt 0x800B0100  servicing\Packages\Microsoft-Windows-Client-LanguagePack-Package~31bf3856ad364e35~x86~pt-BR~6.1.7600.16385.mum  servicing\Packages\Microsoft-Windows-Client-LanguagePack-Package~31bf3856ad364e35~x86~pt-BR~6.1.7600.16385.cat  Package manifest cannot be validated by the corresponding catalog
(fix)   CBS MUM Corrupt CBS File Replaced   Microsoft-Windows-Client-LanguagePack-Package~31bf3856ad364e35~x86~pt-BR~6.1.7600.16385.mum from Cabinet: C:\Windows\CheckSur\v1.0\windows6.1-rtm-client-cab3-x86.cab.
(fix)   CBS Paired File CBS File also Replaced  Microsoft-Windows-Client-LanguagePack-Package~31bf3856ad364e35~x86~pt-BR~6.1.7600.16385.cat from Cabinet: C:\Windows\CheckSur\v1.0\windows6.1-rtm-client-cab3-x86.cab.

Checking Package Watchlist

Checking Component Watchlist

Checking Packages

Checking Component Store

Seconds executed: 224
 Found 1 errors
 Fixed 1 errors
  CBS MUM Corrupt Total count: 1
  Fixed: CBS MUM Corrupt.  Total count: 1
  Fixed: CBS Paired File.  Total count: 1

It seems it has something to do with the Brazilian Portuguese Language Pack, which happens to be my native language. The problem is I can't uninstall the language pack since it is my system default language. And I haven't found any place to download it so I could reinstall it manually. Well, what should I do?


I finally managed to install the SP1. As the problem seemed to do with the language pack, I downloaded the package again through the Windows Update site, reinstalled it, and then I was able to install the SP1. But I really don't know what caused the installation problem in the first place. Maybe those files that appear in the log were really corrupted and the SUR Update had not fixed them. Anyway, since Patches' answer pointed the right direction, I'm accepting it. Thank you all!


3 Answers 3


Try resetting Windows Update's components.

Since that didn't work, run the System Update Readiness Tool which will check your system for any problems and fix them if possible.

Once that's done, check this file for any errors: c:\Windows\Logs\CBS\CheckSUR.log If it indicates there were none or it fixed them, try installing SP1 again. If it indicates errors, post them and we can take a deeper look into what's going on. You might need to reinstall a particular update, or fix missing components of WIndows.

  • It seems this solution only applies to Windows Vista, doesn't it? Anyway, I tried it out, but the problem still shows up when I try to install SP1. Feb 26, 2011 at 0:10
  • The KB article does indicate it's just for Vista but several Microsoft support engineers recommended it for Windows 7. At any rate, Richard above pointed me in the direction of a better solution which I'll post in my answer because I don't think it will fit here.
    – Patches
    Feb 26, 2011 at 22:09
  • Did you run the SUR update?..microsoft.com/downloads/en/…
    – Moab
    Mar 2, 2011 at 18:20
  • Sorry for the delay, guys. After I tried resetting the Windows Update's Components I learned about the SUR update. I installed it and tried to install the SP1 again, but it failed. Then I read Patches's answer update and checked out the CheckSUR.log file. There were some errors that have been fixed. I will update my question with the details. Thanks! Mar 3, 2011 at 15:06

There's an interesting article here containing some of the ways to troubleshoot SP1 installation issues.

It suggests The Windows Update Troubleshooter as your first port of call and then if that fails using the System Update Readiness Tool for Windows 7
The link for the 32 bit version is http://go.microsoft.com/fwlink/?linkid=181491

  • I tried both and I still can't install the SP1. Please, see my question update. Thank you! Mar 3, 2011 at 15:49

Try this solution:

If you have this registry key, just delete it:


  • There is no such key in my Windows Registry. Mar 9, 2011 at 21:16

Not the answer you're looking for? Browse other questions tagged or ask your own question.