I have a Fujitsu Amilo Pi 3560 laptop. Its hardware are the following:

  • Intel Pentium T4300
  • NVidia GeForce GT 240M
  • 3 GB of DDR2 RAM

Since the last summer, I am experiencing a very weird symptom on the machine, and it happens randomly. It was rarely happening a few months ago, but now I experience it once or twice every day. I would be very glad if someone could help me with it.

The symptoms are the following:

  • The system hangs and becomes non-responsive
  • The last second of sound/music played will repeat infinitely
  • The only thing that it will react to is long-press on the power button
  • These syptoms occour together randomly at any time, regardless of what applications or operating system are running
  • The crashes also happen when there is no sound, so I doubt it is related

So far, I've tried the following:

  • Reinstalled the operating system, drivers, etc. Since then I also switched from Windows to Linux, and the problem persists. So I concluded that this is not a software issue.
  • Replaced RAM. Some guys recommended that this may be a RAM issue, but the machine continues to experience these freezes even with the new RAM
  • Tried various graphics card benchmark applications, some of them even heated the GPU above 60°C, but it didn't reproduce the problem
  • I took the machine to warranty repair, but the service was unable to reproduce the issue at all, thus they didn't fix it either
  • I also think it is not related to overheating, because the laptop was also hanging in the middle of the winter (even in barely heated places)

I hope that someone can come up with a solution that fixes this, because it is really starting to annoy me.

Thank you in advance!


Answering some questions that the answerers raised:

  • Yes, my battery is working. It lasts for 1-2 hours. I can't recall whether the freezes happen on battery or only on AC power.
  • The fan is working. GPU and CPU temperatures are usually around 40-50°C, and may go upper under heavy load. The machine can also crash when not under heavy load.
  • The files /var/log/syslog and /var/log/kern.log are empty.
  • I wasn't yet able to find a way to reliably reproduce the problem.
  • You can find the output of smartctl here: http://pastebin.com/vnZqrj4r
  • I ran cpuburn's burnMMX program (in 2 instances so that they can burn both CPU cores) for hours, but apart from heating the CPU up to 72°C, nothing really happened.


This was so long ago that I forgot to update with the final result. It turned out to be a hardware bug and was fixed by a warranty repair. Thanks to everyone for their input! :)

  • Did you update the bios?
    – Moab
    Feb 24 '11 at 20:26
  • Disable sound in the bios if you can, if this fixes the issue, then it is either a hardware problem, or a bios flaw.
    – Moab
    Feb 24 '11 at 20:28
  • @Moab - The BIOS is at the latest version already. I have not yet tried disabling the sound, I will report back on that.
    – Venemo
    Feb 24 '11 at 21:00

This sounds suspiciously like a bad motherboard to me, though it could also be the power circuitry. Run IntelBurnTest (for Windows) or another CPU stressing tool to rule that out first, then if you're unlucky, it could be the motherboard. I'd tell you to check for puffy capacitors, but laptops don't have those big, obvious capacitors like desktop boards do.


In the middle of winter is not important point, if you are using it in warm place (inside your house/in warm car ...).

Since it's not software issue, it might be either

  • RAM issue (you changed it, not likely)
  • Power problem (is your battery working? If not, it might be charger circuit/power adapter problem. If, it may still be charger circuit)
  • CPU problem (if you run for example cpuburn for extended time, is everything still working fine?)
  • Motherboard (whatever in there; hard to debug at all)
  • Heating (is fan working? What are internal temperatures?)
  • Disk problem (not likely, usually doesn't cause your symptoms; you can check it with smartctl)

For example CPU heating sink may fail after shock/vibration, and after that it may get worse.

Best way is to try to find way to reproduce it reliably and then deliver it back to warranty service with instructions.

Check also logs (/var/log/syslog, /var/log/kern.log), there might be some problems just before crash.

  • Olli, I edited my question and provided answers for the questions you posted. I will try smartctl and cpuburn, and will report back the results.
    – Venemo
    Feb 24 '11 at 16:27

Unfortunately, this is likely to be a very hard-to-diagnose hardware problem. For instance, a very slightly bad capacitor in some circuit on the motherboard could do this.

When I was fixing computers, I would do a "binary swap" to diagnose this stuff--essentially, swap out half the components with another working PC and and see which one "inherits" the problem. If it's the "donor", then one of the parts that was swapped must be the problem. If it's the "recipient" then it's one of the unswapped parts. Then you swap individual pieces until you figure out which one is bad. Unfortunately this requires you to have another working identical laptop, which probably is not practical.

You could try the "neighborhood garage" technique, which involves swapping parts one at a time until the problem is fixed, but that could get expensive what with restocking fees on stuff like motherboards.

I would definitely try removing all non-essential pieces (the hard drive, for instance) and seeing if that solves the problem. (With the HD out, boot off a Linux LiveCD and work for a few hours.)

I would certainly remove and re-seat every cable that's easily accessible to the end-user. Badly-connected cables can cause incredibly hard-to-diagnose problems sometimes.

  • Minor detail: I would bet my money on using Linux USB stick for booting instead of CD drive, as CD drive is more complicated, and USB is anyway not removable.
    – Olli
    Feb 24 '11 at 20:27
  • It would be hard to take apart the laptop - most of its components are non-replaceable. I also don't have another laptop of the same model to replace mine's pieces with.
    – Venemo
    Feb 24 '11 at 21:34
  • @Venemo, I totally understand. On most laptops, you can in fact disassemble them and remove the keyboard, motherboard, etc. It's just an order of magnitude harder than doing the same thing with a tower.
    – CarlF
    Feb 25 '11 at 18:17

The next time it happens, restart your system, then go to Start -> Control Panel -> Administrative Tools -> Event Viewer, and look in both the Application and System logs near the time you experienced the lockup. This may give you some clues if it's software related.

  • As I said, I use Fedora, so I don't have a start menu. :P Anyway, my kernel log is empty after the restart.
    – Venemo
    Mar 2 '11 at 21:17
  • Ahh. I apologize for not noticing. Try a 'tail -f /var/log/kern.log' in an open visible root terminal. You might be able to catch something before it freezes.
    – LawrenceC
    Mar 2 '11 at 23:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.