I have Windows 7 professional 32-bit with IIS 7.5 installed and configured. I installed the SP1 for Win 7 and since then the IIS is no more working. Even for simple queries like localhost/a.htm (where a.htm is a html file inside under c:\inetpub\wwwroot) leads me to the error:

HTTP Error 503. The service is unavailable.

The IIS worked fine up to SP1 (I have a lot of ASP.NET2/.NET 4 applications on it). I uninstalled the SP1, the same happens. What should I do?



Sounds like your app pool(s) is/are not starting. Open IIS Manager and click on Application Pools, then check the Status column and make sure the all say Started (or at least your DefaultAppPool says Started). If it's not started, right-click on the app pool and choose Start. If you get an error let us know what it is.

Also, what does it say in your application event log?

If a site/virtual directory is configured as an application then the associated app pool must be started and functional in order for it to serve any resource, static or not. Otherwise you'll get a 503 response error. Is the identity of your app pools set to your account? Sounds like you have account corruption happening. Try creating a new (administrator) account and set your app pool to run using that account and see if they start going. Note : Please Check the User who is operating IIS & App Pool should same or assign Network Service User for App pool.

  • Thanks for reply. Almost all app pools are automatically started. I have manually started the other ones. Nothing changed. Anyway, "a.htm" is just a static resource, no need to start an app pool for this, I guess. – lmsasu Feb 25 '11 at 13:51
  • For the event log: "Windows cannot find the local profile and is logging you on with a temporary profile. Changes you make to this profile will be lost when you log off." – lmsasu Feb 25 '11 at 13:57
  • @Imsasu See my edit. – squillman Feb 25 '11 at 14:01
  • Thanks a lot, @quillman, it worked. It seems that the ApplicationPoolIdentity is not able to work anymore. What is the explanation? – lmsasu Feb 25 '11 at 14:21
  • @Imsasu What account was the identity set to? Like I said, it sounds like that account has experienced some corruption and the profile is jacked up now. It happens. – squillman Feb 25 '11 at 14:42

In case someone else trips on this:

I had a url access list reserved that was blocking iis.

cmd.exe -> netsh -> http show urlacl

shows the list of reserved http/https paths. Make sure there is nothing on that list that competes with your IIS port and path.

  • 1
    This saved me when all seamed to fail. Many thanks! – Dandikas Jul 1 '14 at 14:10

Check if your IIS is still enabled (see: http://www.howtogeek.com/howto/windows-vista/how-to-install-iis-on-windows-vista/) and whether the iis service is running (cmd.exe --> services.msc)

  • 1
    IIS is enabled or else you'd get a connection timeout. The fact that there is an HTTP response means that there is an HTTP server running. – squillman Feb 25 '11 at 13:43

Just had the same problem after Win7 SP1 got installed. The problem in my case was Skype: that was listening in on ports 80 and 443 and thus blocking IIS. Told Skype not to do that (there is a checkbox for that in Settings | Advanced | Connection) and my sites worked again.

What the relation is between Skype forgetting that setting and the installation of SP1 (other than it happening at the same time) I don't know.

  • I rarely use Skype, it wasn't that the problem. Thanks for reply. – lmsasu Mar 9 '11 at 10:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.