6

This is a very simple and strange error - TextMate is not opening at all. I have a license fully paid for, I checked my Mac OS X activity monitor and there is no TextMate process running.

Is there a known problem here? Is there a solution?

3
  • 1
    May I suggest that you try opening TextMate from another user account on your system? That´s usually the fastest way to determine whether there is something wrong with the application itself (or its "global" preferences) or with your "local" user preferences. – Asmus Feb 26 '11 at 10:12
  • Anything new on this issue? – Daniel Beck Mar 30 '11 at 19:37
  • What if Textmate is not found under Application Support but the app itself is installed? – David Haddad Jul 12 '12 at 11:11
11

This has happened to me a couple of times after catastrophic system fails (OSX dying without being able to properly shut down all running applications). If that happens while TextMate was running, a stale PID (Process ID) file could remain behind.

Try deleting ~/Library/Application Support/TextMate/TextMate.pid

That usually fixes it for me.

0
1

What does the Console log (in the /Applications/Utilities/Console app) say when you try to open TextMate? Use the Logs button in Console to browse for TextMate crash logs. What do they say?

Have you tried downloading and installing a fresh copy of TextMate?

Look in ~/Library/Preferences/ for a com.macromates.TextMate.preferences.plist file or other TextMate preferences files and move them out of there to your Desktop. Does TextMate open now?

1
  • I offer com.macromates.textmate.LSSharedFileList.plist com.macromates.textmate.blogging.txt com.macromates.textmate.getbundles.plist com.macromates.textmate.latex_config.plist com.macromates.textmate.plist com.macromates.textmate.python com.macromates.textmate.webpreview.plist in my ~/Library/Preferences/ directory. The best way to find them is to open Terminal and entering ls ~/Library/Preferences | grep textmate. – Daniel Beck Feb 26 '11 at 10:22
0

Another way to find what's going on is to lauch the actual executable from the terminal (found in Applications/Utilities/).

Right click on the TextMate icon and choose "Show package content" (or whatever it's called, in french it's "Afficher le contenu du paquet"). Then browse to Content/MacOS/ and double-click on the executable.

You'll get an error message in a terminal window that can be either sent to Allan, TextMate's author, or added to your question here.

0

This happened when I loaded a massively massive text file by accident. I killed the program but it looks like it had stored the file in a recovery area. Every time I tried to load Textmate afterwards, it turned out the reason it wasn't loading right up is that it was attempting to recover this massive text file.

It solved itself by letting the file finally load, then just naturally closing the instance.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.