I am trying to install an old app on Windows 7 64-bit and I am encountering the following error:

The program can't start because MSVCP50.dll is missing from your computer. Try reinstalling the program to fix this problem.

I tried downloading the DLL from various sites on the net, but it won't register (yes, i tried registering it on the Admin command window. The error was pretty curious itself (e.g. not the standard can't find entry point)

The module "c:\windows\system32\msvcp50.dll" failed to load.

Make sure the binary is stored at the specified path or debug it to check for problems with the binary or dependent .DLL files.

The specified module could not be found.

How do I resolve this issue?

  • Try dropping the dll into the program folder where the program executable is. Some programs are coded to check there before moving to the system folder to look for it. Also try dropping it into the SysWOW64 folder and try registering it. You may have the wrong version of the dll, try copying one from a XP PC. – Moab Feb 28 '11 at 18:16
  • @Moab Didn't work. I think the DLL has some dependencies and that is why it's not registering. – AngryHacker Mar 1 '11 at 0:36
  • Try installing the program in compatibility mode with admin, right click on the installer ans select properties, then compatibility tab, set compatibility to XPsp2 and tick run as admin, hit OK and try installing it again. – Moab Mar 1 '11 at 0:55
  • I found this program, it can identify DLL dependencies in program executables...mark0.net/soft-bdllscan-e.html – Moab Mar 3 '11 at 0:07

The problem is probably that msvcp50.dll requires one (or more) additional dlls to work. If you don't have these then the registration will fail.

I'm not in a position to check what extra dlls it might need at the moment, but I would be very wary of downloading this from a non Microsoft site. You don't know what you might be getting.


I encountered this problem when trying to run Editeur on Win7 64-bit. Placing the DLL into the directory where the executable resides resolved the problem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.