I just tried to install Windows 7 x64 SP1 on my desktop computer, but 10 minutes into the installation I get this error:

The filename, directory name or volume label syntax is incorrect.


My guess is that I have to reinstall the OS, but I'm wondering if I somehow can get a more detailed error message. I want to know what has got the wrong name/path? Anybody know?

  • Which version of Windows? I think all versions of windows have a service pack 1 by now. – Majenko Feb 28 '11 at 19:19
  • Oh, did I really forget? 7 x64. – Eikern Feb 28 '11 at 19:34

I ended up having to re-burn the installation media which helped me get past this error message.

| improve this answer | |

I've run into this problem once. Strange thing it was, it didn't even bother to ask me for the product key. It just attempted to activate "empty handed", as far as I was concerned, but failed with 0x8007007b.

From here I successfully got to activate with no reinstalling, here is what I did, I hope it helps you:

tl;dr short version

you fire up a cmd.exe with administrative privileges

slmgr.vbs /ipk Y0URQ-F4V0R-IT3QP-R0DUC-TQK3Y

to overwrite your product key (care to replace dummy key from this example).

If you got the same problem as me, next time trying activation should be successful!

note: you may also be interested in other options, if you give no parameter, it pops them up in dialogs. in particular, read the help for /rearm, it promises to "Reset the licensing status of the machine". I didn't try it.

(long) nothing to do this afternoon, let's read version

You may have tried to install windows over an old windows installation from which the installer pulled some old information out, even if you formatted, for example via the system partition used for booting.

There is a Microsoft tool called mgadiag.exe, stands for "microsoft genuine advantage diagnostics". You can obtain version 1.9.0027.0 through a link I got from some less-important kb article 938720:

needs administrative privileges, when you run it, check out whether you have already a product key installed without you even knowing it on the windows tab.

Also check out the license type field. it may stand for Windows License Type: KMS Client. in this example, we have kms, it is key management services. it is related to windows volume licensing. if you are a home user, you probably can't or won't want to go with volume licensing, it may be there by mistake (eg. shop installed stuff previously, forgot to remove? etc.).

go to licensing tab, check out Description field. (note there is a copy button in case you want to copy the information for asking help).

in the description field, you may see the initials KMS.

if you are in the kms situation and want to get rid of it, try slmgr.vbs what the licensig tab advises:

Please use slmgr.vbs /ato to activate and update KMS client information in order to update values.

it is a command line visual basic scripts that A.F.A.I.K. should come with the OS, built-in.

you can try and install a new product key. start a cmd.exe with admin privileges: in start menu search box, type cmd.exe, if you have an exact hit (you should), right click it, choose run as administrator. now you can install a new product key:

slmgr.vbs /ipk Y0URQ-F4V0R-IT3QP-R0DUC-TQK3Y

(beware it is a dummy, invalid -I guess- product key used in the example, should anyone miss that)

Make sure, after you run it, to find the dialog where it notifies you about whether it succeeded changing the key. After I OK-ed that, I run activate again, and activation was successful now!

If you care to check, if you run mgadiag.exe again, the key type now may have changed to whatever else.

If you feel curious, starting slmgr.vbs with no parameters pops up possible switches in dialogs. In particular /rearm sounds interesting, I didn't use it though.

| improve this answer | |
  • I had the same error (though after installing, upon running the activation wizard), and this solved the problem. As noted in this answer, don't forget to run the activation wizard (Control Panel > System and Security > System > Windows activation) after running the command. – Nicolas Raoul Jun 11 '18 at 3:36

Do you have RAID array or Storport setup as your c: . Often, these 7b errors occur when the driver for your non 101 ide controller is missing.

Is it perhaps an older motherboard with an nVidia MCP on it?

| improve this answer | |
  • The computer is two years old, and pretty new. I haven't got any RAID arrays or anything, but I once tried to change the default %programfiles% to my D: disc (because I have a smaller 10000RPM system disc), I reverted it after a week. – Eikern Feb 28 '11 at 20:29

Its probably happening when it is trying to create a Windows system restore point.

See if doing this cures the problem. your system restore Available disk list may look slightly different, remove the entry labeled (missing)

Resolution Click Start, type SystemPropertiesProtection.exe. The System Restore Properties window will open.

You may see two C: drives in the listing with the same Volume label (see figure below). Deselect the checkbox for the duplicate volume, and enable the checkbox for the correct drive (the one with Windows logo).

enter image description here





If this is not the case, turn off system restore, then turn it back on, try SP1 again.

If no Joy, disable your Security Software during the installation of SP1 by doing a clean boot, open msconfig:

Click the Startup Tab and uncheck everything

Click the Services tab. Click to select the Hide All Microsoft Services check box. Click Disable All, and then click OK. When you are prompted, click Restart, then install SP1

You can revert the msconfig changes after SP1 is installed successfully.


| improve this answer | |
  • All of my drives (C:, D:, and E:) are only appearing once. – Eikern Feb 28 '11 at 20:31
  • Check my edit above – Moab Feb 28 '11 at 21:01
  • Doesn't seem to work unfortunately. – Eikern Mar 8 '11 at 11:13
  • Disable Windows System Restore, the turn it back on and create a manual restore point, then try SP again. – Moab Mar 8 '11 at 22:21

Try turning of AHCI and see if it allows you install after that. I've seen this issue a few times and it always related to the RAID controller, or enabling/disabling AHCI. Unless your running a SSD, using AHCI doesn't offer any tremendous benefits.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.