So I have a GA-p35-DS4 mboard with a Q6600, running windows7-x64. After a random crash with a bluescreen (not caused by anything particular as I recall), none of the usb-controllers are working. (And none of the devices connected to those usb ports).

All the controllers are showed up in the device manager, but every one has a warning-icon (as they are not functioning properly). The windows identifies them correctly, it shows exactly the model of each controller, and it says that the driver is installed. Now, when I try to reinstall the driver (Update driver menu item in the device manager), it tries to find it, finds the driver, but quits saying "Windows found driver software for your device but encountered an error while attempting to install it." Additionally, it displays "This operation requires an interactive window station", whatever that means...

Now get this, the same thing happens with a new pci-usb controller card! It is found (actually each time the machine starts, it is found as new hardware), but trying to install drivers leads nowhere, I am getting the same message about an interactive window station. (tried to install drivers from the acoompanying CD)

I have tried deleting those devices from device manager and let windows find them again, but that leads to same results.

Update: Now I have also tried deleting the infcache.1 file in windows/system32/driverstore directory. After a restart it was trying to find drivers for like 10 minutes (rebuilding the cachefile for sure), but in the end things got back to the problematic state. Only now the non-working controllers show up as "Universal Serial Bus (USB) Controller". i.e., not as their model names like before.

None of the ports on this extension card work either.

This should not be a hardware problem, a usb keyboard connected to the builtin usb controller works in bios, and even in another OS running the same computer (old xp installation)

What to do?

Will I have to reinstall? Can deleting infcache.1 help? Is there some way to let windows remove all old drivers and try to find all hardware again, this time only looking for drivers on a windows install disk or something?

  • Update your chipset driver if it is an Intel chipset. – Moab Mar 2 '11 at 22:03

Use the windows disk to re-install drives. I would say the hardware is fine, just your drivers have gone for a swim.

Alternatively, go to the motherboards website, download all the latest drivers and re-install them. No need to really uninstall old drivers unless manufacturer says so.

There is no way to let windows re-install all drivers, unless you do it manually. Just make sure when you run update driver from the windows device manager, that you choose the disk correctly.

the pci-usb card will use the same device drivers, maybe.


run a windows repair using the windows disk from boot. This will take awhile but should also repair the drivers for you.

  • What do you mean when you say "reinstall drivers manually"? Like I have said, when I go to device manager and press the Update driver menu item, I get the "needs interactive station blabla" error. The same thing I get when I try to point it to the new driver location. I have tried doing this with the latest drivers from Gigabytes website, same result :/. – Cray Mar 2 '11 at 15:25
  • Did sort of this, but very manually, copied .sys files that seemed appropriate from a similar machine's windows directory :P, that fixed the problem. – Cray Oct 29 '12 at 13:11

Try uninstalling all the USB hubs and devices in device manager. Reboot and let windows rediscover and reinstall drivers for them.

  • Am not sure if you didn't read the whole question or if it was is unclear, but that was one of the first things I've tried, still the same result... – Cray Mar 2 '11 at 20:28
  • I thought maybe you've meant that I should not only remove the usb controllers but also all the devices that were originally connected to them. I have tried that too, same result. However it finds devices if some are connected to usb ports. (It doesn't find the right driver, but the device shows up at least. (so this is almost certainly a software problem, since usb bus seems to work and find some device at least)). – Cray Mar 2 '11 at 21:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.