2

My printer is a HP Photosmart 2575. When I print from my Windows XP the margins are all ok, but when I print from my Windows 7 laptop the top margin is 2x larger for the same document, and as a result the bottom is cropped.

I've already found one (http://h30434.www3.hp.com/t5/Printer-All-in-One-Software-and/Deskjet-5150-printer-incorrect-margins-with-Vista-64-bit/td-p/103166) thread in HP forums from someone that seems to have the same problem than me, but no solution is provided.

My Windows 7 is the Home Premium x64.

Can anyone help me?

  • Is this happening from all applications and all documents, or only specific ones? – hdhondt Apr 29 '15 at 23:24
  • Have you checked the printer preferences are the same in both pc's? – c_str May 11 '16 at 0:01
  • Print your document to a PDF. See if the PDF looks OK. You may want to print the PDF, but I doubt it will solve your problem. This was an issue for me for another type of printer, and found that it was about the driver. For a quick fix, can you print with (-) margins or some default offsets in the printer setup? If it is about drivers, it may be difficult to solve it right away. – berkus Jul 4 '17 at 18:20
0

Have you checked that on the Win 7 machine the default paper size is correct in the printer settings - eg: A4 instead of Letter

  • Of course I've checked – rguerreiro Mar 3 '11 at 23:33
0

Are you using the same version of Microsoft Office? Windows XP computers tend to have the elder Microsoft Office 2000, while Windows 7 usually comes with a newer version. The newer version has a very different interface, and a different way of dealing with page margins as well. It may be the case that, when you import a document edited with an elder version of Microsoft Office, the newer version interprets margins in a different way. Remember that older extensions have only three letters whereas newer ones have four and typically end with an x (.doc > .docx; .xls > .xlsx; .ppt > .pptx; etc.). If this is indeed the case, it will be solved by simply opening the page properties in Windows 7 and re-setting the values desired.

I hope you can get your problem solved, bye.

0

Try one thing. Print with another printer; a PDF printer in case you don't have a second physical printer This will clarify if windows is messing it up or the printer...

also try using windows default printer drivers instead of HP drivers (or vice versa)

-1

same problem here, but i finally found the solution go to devices and printer and right click your printer name the click the PRINTING PREFERENCES then choose the paper you want to be print on, in the print paper size in quick setup and in page set up. I hope this will help!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.