I am trying to get read/write support for NTFS drives, under Mac os 10.6.

I have tried to use NTFS 3G, but it seems it does not support 64 bit kernels. I was unable to change my Mac's Kernel to 32 bit.

Is there a solution?

I am running Snow Leopard, under a 2011 MBP13

I am getting the following error.

Error message

After running system_profile | grep Kernel I get:

ForkProBox:~ fork$ system_profiler | grep Kernel 
      Kernel Version: Darwin 10.7.1
      64-bit Kernel and Extensions: Yes

I have ran the commands suggested here is their output Error tracking

  • Why are you running the 64 bit kernel? When you run system_profiler | grep Kernel in Terminal, what does it say? Have you installed a recent version of MacFUSE?
    – Daniel Beck
    Mar 5 '11 at 7:02
  • I have just bought my 2011 Mac. It came with the 64 bit Kernel. Mar 5 '11 at 10:46
  • According to here, NTFS-3g on "10.6 requires that you do not use the 64-bit kernel". So there's no way around that, except buying the commercial version that has 64 bit support. You didn't mention how you tried changing back to the 32 bit kernel. Doesn't e.g. this or this work at all?
    – Daniel Beck
    Mar 5 '11 at 10:53
  • I have tried an option that you did not have listed, but it failed. I however found an alternative to NTFS-3G. I am using SL-NTFS which uses Mac OS X own support for NTFS. Mar 5 '11 at 17:24
  • I'm running Mac OS X 10.6.8 ~ Kernel version Darwin 10.8.0, on a 2011 MBP15, and encountered the same problem with MacFuse (same symbols are missing for x86_64). Using MacFuse 2.1.7 beta (from here: macfuse.googlecode.com/svn-history/r1658/releases/developer/…)
    – Dan
    Jul 8 '11 at 19:50

After so many tail arounds I went with Mac OS X own support for NTFS read/write.

For that I have used SL-NTFS.

  • Your link is broken
    – Rick Smith
    Apr 15 '15 at 21:01

The kernel would not report a link error if the problem were a missing architecture in the kext. More likely is that it depends on symbols that are no longer present.

Set FUSE="/Library/Filesystems/fusefs.fs/Support/fusefs.kext", then please edit your question to include:

  • the relevant bits from your kernel log and/or the output from sudo kextutil -t -v 2 "$FUSE" and sudo kextutil -t -v 4 "$FUSE"
  • the output from kextlibs -c -all-symbols "$FUSE"
  • the OSBundleLibraries and any OSBundleLibraries_x86_64 elements of "$FUSE/Contents/Info.plist".

You should also contact the MacFuse developers, since a link error generally indicates a bug on their end.

ETA: The logs indicate that MacFuse linking falters on the functions OSRuntimeFinalizeCPP and OSRuntimeInitializeCPP. From the kextlibs output, it looks like these symbols are published in the i368 and ppc kext libraries. It looks like MacFuse relies on some private kernel functions outside of established kernel programming interfaces. Lion (that's what the Darwin 10.7.1 kernel corresponds to, yes? I'm running Mac OS X 10.6.6, and it reports kernel 10.6.0) has apparently changed some things in the kernel, and this has broken MacFuse.

I am glad to hear that SL-NTFS seems to be working well for you.

  • I have added the output of those commands to my question. They were too big so I have putted them in a github gist. Mar 5 '11 at 10:57

From Use MacFuse to read and write to NTFS volumes :

  1. Downloaded the latest MacFUSE package (dmg from Google)
  2. Installed MacFUSE package and restarted the Mac
  3. Downloaded the NTFS-3g package
  4. Fixed the "macfuse_required" error (tip from InsanelyMac)
  5. Installed the NTFS-3g package (no restart)
  6. Plugged in my NTFS-formatted USB2 external drive (which wouldn't even mount before) and it just appeared on my Macbook's desktop - read-write!!!

Note: The links from the thread didn't work, so I tried to find new ones, with no guarantee that they do work. So make sure first of your backup.

  • Just wanted to note that MacFuse is no longer being maintained.
    – Rick Smith
    Apr 15 '15 at 21:03

Are you sure you have the latest release of NTFS-3g? Right now it's 2010.10.2, and it supports 64-bit x86 kernels. I have it running on a Mid-2010 27" iMac, and it works just fine.

  • I am running exactly that version. Mar 4 '11 at 15:16
  • I have added a picture of the error I get everytime i plug a NTFS drive. Mar 4 '11 at 15:43
  • Maybe go into the MacFUSE options, enable checking for beta versions, and update to the latest beta? What's in the error logs?
    – afrazier
    Mar 4 '11 at 16:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.