I have an extremely weird issue with my WiFi router. Both Ubuntu & Windows 7 can connect to it fine, but after 5-10 minutes browser (any one) stops opening pages and tells me it cannot resolve host address.

But, at the same time, tools like Skype or BitTorrent work without any issues. I can also browse Internet on my mobile phone connected to the very same router.

If I reset router it helps, but after 5-10 minutes I see just the same problem... Ubuntu tells me that WiFi signal is lost (mobile sees it), Windows 7 just won't let me browse anywhere.

Can anyone give me a suggestion on this, please?


  • I've had this issue when my local network and its users/programs simply requested too many DNS lookups for the router/ISP to accept. – oKtosiTe Mar 4 '11 at 21:21
  • Might be.. But this problem occurs even if I run browser only and no other background network applications – Anton Mar 4 '11 at 22:09

Have you tried using a wired connection to the router (assuming your wireless-router has some wired network sockets)? If wired works, then it's almost certainly a WIFI issue and very likely has to do with your laptop wireless card and/or with interference from other WIFI devices. Also try having the laptop within a few feet of the wireless router. If that keeps the problem from showing up, then interference could be a contributing factor.

  • In fact, I resolved my problem by just switching the WiFi channel in settings of my router. I was not aware of the interference in my location, now I am :) – Anton Mar 4 '11 at 23:15
  • So, I will accept your post, since it's the closest to the solution ;) – Anton Mar 4 '11 at 23:15

Since Skype and BitTorrent don't rely on DNS quite as much as browsers do, you may be having something wrong with your DNS settings. Try explicitly putting (Google DNS) as your primary nameserver (removing all the others, if any).

  • Well, in Windows 7 it doesn't help if I switch to Google DNS. Maybe, I'm just setting it wrong? Or can it be overwritten somewhere else... – Anton Mar 4 '11 at 22:01
  • And anyway Ubuntu tells me that Wifi signal is lost, so it's not likely a problem with DNS on this system... – Anton Mar 4 '11 at 22:07

I've had this problem and it was all dependent on the ISP. You might want to call your internet service provider, to see if they have any tips on boosting your signal.

  • Yeah, but communication with those guys sucks and that's why I came with my issue here. All they tell you is "there must be a problem with your laptop" :) – Anton Mar 4 '11 at 22:02

Before contacting your ISP, first determine if you are dropping connections to the router, or if your modem is disconnecting. You can do this through the following:


ipconfig // read what the "default gateway" IP is

ping <"default gateway" IP> -t

optimally the time for each ping should be <=1ms.

When your browser drops, see if the ping is still working. If you get "destination host unreachable", the problem is your internal wifi connection not being strong enough. In this case, purchasing some high-gain antenna for you router and PC should solve the problem. Alternatively, use a wired connection.


I had the same problem but the other way around. My laptop was fine but phone was dropping signal. I'd then have to unplug router and it would be fine for a while. I changed the channel on the router from auto to channel 11 and it seems to be working well, three days with no drops. I noticed it would drop always when I put my PC to sleep or my girl got off her PC. Strange, but changing channel may fix this issue.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.