3

In zsh when I try and press CTRL-C nothing happens (it works fine in bash) when I run bindkey | grep \\^C I get "^C" Applications so something must've happened... how do I bind ^-C to the default?

  • What are you trying to do with Ctrl-c? What does stty -a show (with respect to intr and ^C (in a freshly started zsh session)? – Dennis Williamson Mar 5 '11 at 1:30
  • go to a new line in the shell, and intr = ^C; – errorhandler Mar 5 '11 at 2:09
5

stty sane is usually a good starting place; outside of the zsh command line editor, it's a function of the terminal driver.

  • now bindkey | grep \\^C returns nothing... – errorhandler Mar 5 '11 at 0:27
0

I just solved this situation by typing in the simple command ls after pressing ctrl-c, ctrl-c.

I think I was in some kind of multi-line input mode.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.