I'm trying to boot an XP installation cloned into VirtualBox from a real drive. I'm getting the message

A disk read error occurred
Press Ctrl+Alt+Del to restart

whenever* I try to boot the machine.

* This is not strictly true: with AMD-V enabled, the boot process appears to not make it this far and instead hangs at a black screen with cursor.

I created the VirtualBox image from the original drive using the following method:

$ sudo ddrescue -n /dev/sdd sdd.img logfile  # completed without errors
$ VBoxManage convertfromraw sdd.img disk.vdi

The original disk (and the image) contain a single NTFS partition with XP installed on it. The owner of the drive indicates that it did boot okay the last time the system made it that far. The (Pentium 4) system has a broken (enormous) heat sink, so at some point it failed to boot because it would quickly overheat and shut down.

If I boot the VM from a live cd, I am able to mount its /dev/sda1 without any problems. I ran ntfsfix and didn't have any luck.

I've read through the instructions on doing this. I didn't really follow them. For example, I didn't run MergeIDE before imaging because the machine was not bootable. However, the symptom of that problem seems to be quite different.

The emitted message is contained in the volume boot record of the XP partition, which leads me to suspect that this is a problem with the core operating system bootstrap procedure, and not related to anything in the registry.

I don't have an XP boot CD.

  • I have just resized partition and left 20MB unallocated space and it fixed the problem (for my 700MB XP VHD). Sometimes leaving 8-10MB works fine, sometimes - 50MB. However, leaving 100MB unallocated space always did the job. Sadly Windows XP has no built-in tool for resizing partitions, so you must use 3rd-party tools.
    – Jet
    Feb 4, 2015 at 17:00

1 Answer 1


Check the Storage area of the Settings window of your virtual machine. Your virtual hard drive is likely attached to the SATA Controller as in this example: VirtualBox hard drive settings - attached as SATA

The original system very likely had an IDE hard drive not a SATA drive, which means it will not have any SATA controller drivers installed and won't be properly configured to boot from a SATA attached drive (be it real or virtual). Attaching the virtual hard drive to the IDE controller might allow the system to boot.

To do this, click on SATA Controller in the Storage Tree, and select the Remove Controller button (the rightmost button directly beneath the Storage Tree box). If you don't already have an IDE Controller, add one by clicking the Add Controller button (directly to the left of the Remove Controller button) and selecting Add IDE Controller. Then, click on IDE Controller and click on Add Attachment (leftmost button) and choose Add Hard Disk. Then select the appropriate hard disk image and give it another shot.

If it still doesn't work, you can try the different settings under Type when you click on IDE Controller and see if that helps any.

  • 3
    I've tried connecting it to IDE, SATA, and SCSI — it doesn't seem to make a difference. Also tried the different types of IDE and SCSI controllers. No dice.
    – intuited
    Mar 5, 2011 at 15:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.